Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > jeep wont start

Join Wrangler Forum Today


Thread: jeep wont start Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-24-2013 09:39 AM
Dustman1
Quote:
Originally Posted by Dustman1 View Post
Check all your grounds . Crank position sensor might be your problem. Also check and see if your cam sensor is getting power. It can be a number of things. Best bet use an ohm tester and start tracing wires. Good luck
Start with basics first
Fuses , corroded wires , etc.
03-24-2013 09:37 AM
Dustman1 Check all your grounds . Crank position sensor might be your problem. Also check and see if your cam sensor is getting power. It can be a number of things. Best bet use an ohm tester and start tracing wires. Good luck
03-22-2013 11:26 PM
WICruiser What you decribe is a relay problem that is not providing power to the computer for either the fuel or ignition circuit. If you have replace relays without any change the problem is likely in the socket the relay in question plugs into. You can confirm the overall lack of ignition with a timing light on one of the spark plug wires. If you have ignition the other potential is no fuel, pull a spark plug and look to see if it is wet. It could be that the relay in question is the fuel pump relay such that you are not getting any fuel pressure and therefore no fuel delivery.
03-22-2013 10:13 PM
1stmudmaster
jeep wont start

ok, i just bought a 95 wrangler and there is a problem with it starting. it will crank over good but wont start. please dont say starter, battery, alternator lol. its not that. when you turn the key forward there is a clicking in the fuse box under the hood. after 10-15 min the clicking will stop and it will start right up. and its not a relay, all have been replaced. im thinking corrosion but we cleaned it best we could and no change.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC