Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > CJ Jeep Forum > CJ General Discussion Forum > need some help BLINK BLINK

Join Wrangler Forum Today


Thread: need some help BLINK BLINK Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-18-2013 10:18 AM
gcaughron Try a new flasher. If this doesn't fix it then check the turn signal switch in the column.
04-08-2013 04:07 PM
Goofyjumper Sounds like your turn signal flasher relay is bad. The turn signal flasher relay is separate from your hazard relay.
04-07-2013 12:23 AM
sofiyj
need some help BLINK BLINK

hey all im posting this for my brother in law. He bought my 92 yj with cj front clip conversion. He is currently hooking up the electrical in the front and he is having problem getting the blinkers to blink. The hazzards will work but the blinkers will not...... he needs some help guys


This is my first rebuild its a 92 Sierra with a 94 bucket, and the grill and hood from a cj. I had to cut the parking light harness to make it work with the cj parking lights. All the lights work fine and the side markers flash with the hazards but when I want to use the blinker it just turns the light on without blinking. I plugged it into my spare steering console and it did the same thing. Any help?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:04 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC