Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Clutch Question..

Join Wrangler Forum Today


Thread: Clutch Question.. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-25-2009 01:31 PM
Timberman C'mon guys.. Anyone have any ideas? Jerry, where are you sir??

Timber
04-24-2009 10:42 AM
Timberman
Clutch Question..

Hey All!

I think I may have a bit of a situation here.. When I travel on long distances; my clutch begins to act different. It still shifts like a dream, but it seems as though the last 2 inches or so when i depress the clutch it gets a little squishy.. I guess squishy really isn't the best description, but seems as if the last couple of inches, the clutch feels almost as if it is rubbing on something...

Again, no problems with shifting, just an odd occurrence over long trips. When I am driving around town it wont do it at all.. Just smooth as silk.. It only happens when I have been on the freeway for 30+ minutes..

Any thoughts guys? is there fluid in there I should change?

Here is the pertinent info:

2000 Wrangler Sport
NV3550 5 speed manual..

Transmission Fluid Change: Less than 1000 miles ago


Thanks for the help!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:06 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC