Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Off Road and External Lighting > Lighting Troubles.

Join Wrangler Forum Today


Thread: Lighting Troubles. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-18-2013 08:09 PM
htkrph
Lighting Troubles.

Alright. Installed the JK turn signals on my grill about a month ago. That day my Battery died. I was able to keep running the jeep with the bad battery for a couple of weeks. Alright that day the turn signals worked great; but the passenger front turn signal was not flashing, the back passenger was flashing like the lights were out. The turn signal is on. Just steady not the high light like if its blinking. the side marker is not coming on. The Driver side front turn signal is on and turns perfectly so does the back. No problems on the driver side. My HiBeams are not working either. So Last week I got a new battery and is working great! But the lights are still bad. I checked the fuses, I put a new plug on the side marker to see if it would work and nothing. I dont know if any of this makes sense. but its driving me nuts. I need to get a safety inspection and no way i'm passing it like this. Any suggestions ?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:28 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC