Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Help! Clutch Issues

Join Wrangler Forum Today


Thread: Help! Clutch Issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-19-2013 12:21 PM
Jarhead1127 Hey I have a 90 YJ and mine was doing that 2 days ago. I hade to replace the slave cylinder on mine cause it was leaking fluid. I wasn't able to put it into gear unless the jeep was cut off. Good luck to you and getting it back on the road!
04-19-2013 12:16 AM
91_YJ_Cali PS--- Thank you for all of the input, I am having some luck with CHURP by using oil detergent in the oil to clean the values and lifters
04-19-2013 12:13 AM
91_YJ_Cali Ok guys... so I when to Autozone and bought a CMC (Clutch Master Cylinder) and ran home and took the old one off. When I went to install the new one, the metal flange around the new CMC was thicker than the old plastic one and the mounting bolts from inside the cab to the engine compartment are too short!!! What the HECK!! I went to replace the bolts and it looks like they are welded to the clutch petal mounting bracket.

Has anyone else run across this issue? What do I do? I cannot take the bolts off and I know have looked online and all of the replacement CMCs are metal and the flange thickness looks the same. How do I replace the bolts cause they are not coming out from what I can determine.
04-13-2013 12:32 PM
SoILJeepGuy had the same issue, mine was the master cylinder, it was leaking out of the rod that attaches to your clutch pedal. check the resevior and see if you're lossing fluid ? if so, there is your problem!! I just replaced mine with one from Autozone for like 35 dollars and problem solved! also make sure you bleed the system correctly so you don't have air in your line. I think there are some how-to's on here if you can't figure it out .
04-11-2013 02:28 PM
caposto There's not much to the clutch hydraulic system. You've got an internal slave, the CMC, and some lines. If there's no leaks and the slave is new/good its gotta be the CMC.
04-11-2013 07:58 AM
AllMudd What trans do you have? I have the AX5 and I had the same issue about 9 years ago. While I was tryin to replace just what was bad wasn't helping, same issue arose. I ended up having to buy the whole master and slave cylinder assembly from the dealer and I haven't had a problem yet.

For your other issue if it sounds internal to down to your local auto parts store and pick up a bottle of Sea Foam. Put it in the engine oil and run it for about 20-30 mins. Then do an oil change to see if it helps your little chirp.
04-11-2013 07:44 AM
bigb996 it sounds like the master cylinder needs replacing to me. I bought the Luk clutch kit and put it in as well and it has been good since. My slave cylinder had gone bad initially. I would look underneath and see if you see any leaks and if not pick up a master cylinder and swap it out(very easy to do). If that doesnt fix it, you could have a bad slave cylinder.
04-11-2013 02:41 AM
91_YJ_Cali
Help! Clutch Issues

Ok team here goes.

I just bought a YJ about 2 months ago and I needed to replace the clutch after driving it for 4 weeks and realized that I was having to pump the clutch petal 2 or 3 times to get the pressure to built up so I could shift gears.

So I ordered a LUK Master Cluth Kit and has a shop replace the clutch and flywheel. I have now drive the jeep for 4 weeks and know I am having to same issue and if I sit still with the clutch engaged and the jeep in gear, the pressure drops and I cannot shift without pumping the clutch petal to shift or take it out of gear (the jeep starts to inch forward while the clutch pressure drops).

I think I may have a bad Clutch Master Cylinder and I need to replace that now as well. Any thoughts?

Also, on a different topic, I have started to hear a chirping noise from my engine. I think it is the values, I think they are sticking. Any way I can fix this?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:32 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC