Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Suspension noise

Join Wrangler Forum Today


Thread: Suspension noise Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-24-2013 12:34 PM
wrangler dad 73 John there should be a tight fit with your bushings and this is most likely where the noise is coming from.
There are two things you can try to resolve this issue.

1 make sure you have the correct length on your link arm itself. to adjust the length loosen the tightening bolt just behind the heim joint (or whatever joint you have) remove the bolt that connects the link arm to the axel and lengthen the arm by rotating out the joint a half turn at a time until you find the right length and re-install

2 make sure you have the correct size bolt that holds the link arm to the axel if the bolt is to narrow then it will cause vibrations when driving. Just reinstall a thicker bolt.
04-24-2013 12:10 PM
hooked422
Suspension noise

Ok after dealing with the dreaded dw I fixed it 90 percent got a new track bar and new tires. But.... There is still a loose sound coming from the front end when I hit bumps. I looks under the jeep took a rubber mallet and tap suspension components to ate if they sounded loose. Is their supposed to be a little movement on the upper control bushings? Any help is much appreciated.

John

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:26 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC