Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 03 Wrangler Transmission Issue?

Join Wrangler Forum Today


Thread: 03 Wrangler Transmission Issue? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-25-2013 06:00 AM
lakeeriemonster04 The old fluid looked okay it didn't have a burnt smell and it still had a nice red color to it.
04-24-2013 08:32 PM
TJGARMA03 Slips are always not good! Just drive it with overdrive off all the time then. The 42rle always had a bad wrap. It's a 3 speed with overdrive(4th pretty much). What was the fluid like when you change it? Black? Burnt? Make sure to only use ATF+4.
04-24-2013 07:46 PM
lakeeriemonster04
03 Wrangler Transmission Issue?

I recently purchased a 03 TJ 4.0 145,000 miles with an automatic transmission and noticed when driving with overdrive on the transmission seems to slip (rpm's jump up) as it goes from I think 3rd to 4th gear. I have recently changed the filter and fluid hoping it may help but it didn't. All other gears shift fine and only seems to happen if I leave the overdrive on. Could this be my transmission going bad

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC