Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Oil pump tricks

Join Wrangler Forum Today


Thread: Oil pump tricks Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-14-2014 11:06 AM
steelslinger I actually received a bad new oil pump. There was a small crack on the press fit plug in the side of the pump. It airated the oil
08-21-2013 08:38 PM
steelslinger I just replaced my oil pump because I had a lifter hydraulically fail and I thought due to low oil pressure. After a tense 15 minutes of 2000 rpm run time at 18 psi followed by a 1 hour set time my pressure is still about 10 psi at idle. Better than the 0 psi at idle during that 15 min. I will be changing my pick up as it didn't fit as tightly as I would like. I will update this after but right now Id say a new pump will not make it better. By the way I also replaced all the lifters, timing chain and gears.
04-28-2013 04:32 PM
masterbartender69 5/30, forgot to mention that I can drive forever with it at normal pressure, it doesn't drop and stay until I slow down. That's where I am confused, I would think that it would go low no matter what
04-28-2013 11:01 AM
jeepwayoflife If you already replaced the oil sending unit, I sure wouldn't drive it with only 5psi of oil pressure... To answer your question, if you are sure the sending unit is working and the oil pressure is that low, you should replace the pump. What weight oil are you running?
04-27-2013 10:43 PM
masterbartender69 What weight?
04-27-2013 10:25 PM
jeepdude2003 Run lucus oil its so thick it will be a bandaid if I remember right
04-27-2013 10:21 PM
masterbartender69
Oil pump tricks

So my oil pressure has been odd. Sits around 40 on start up and goes to around 20 after hitting temp. However, if I slow down it drops lower (5-8) and remains there even after I accelerate/raise rpm. I am assuming I need a new pump as I have changed out the sending unit and oil changed recently. Are there any tricks/tips for changing the pump? Or is there anything else that could cause this. I changed out the water pump recently as well due to the bearing going out. 97 Wrangler 2.5 4cyl

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:50 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC