Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > HID lights not working on low beam

Join Wrangler Forum Today


Thread: HID lights not working on low beam Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-02-2013 04:51 PM
n00g7 While we are here, did you get new E-Code headlight enclosures for the HID's? If not, you will be murdered quickly in a violent fit of road rage.
05-02-2013 03:45 PM
leslie2012 Thanks everyone for your help. I really appreciate it. It turns out that the problem was NOT the HIDs but the wiring that comes from a plug located near the firewall. It took 2 days to go through the wiring with a friend, but we finally got it and now the lights are working perfectly!
04-28-2013 09:14 PM
viperx6x9x if you have dual beam kit. try taking a look at the bulb housings. see if it is possible for them to be assembled backwards.

Mine (different brand) had a different problem. One of them would be low when switch was hi and vice versa.

Turned out it was assembled 180 degrees backwards causing the magnets to reverse polarity. i flipped the housing around 180 and everything works right now.

or option 2, as Jeepn9910 said, did you order the dual beam kit? if you just got the low beam kit, some of them just cut out when you switch to hi beam, they only illuminate on low beam switch. It could be possible they are wired backwards somehow, so that they only work on high.
04-28-2013 06:03 PM
Jeepin9910
Quote:
Originally Posted by leslie2012 View Post

The HIDs are only working in high beam. Won't work at all in low beam. I want them to work in low beam.
Did you order the dual beam kit or just the low beam kit?
04-28-2013 03:31 PM
leslie2012
Quote:
Originally Posted by leslie2012 View Post
Hi All,

I need some help. I just purchased H4 HID kit from hidkitwarehouse.com for my 2003 Jeep Wrangler Sport. I followed the directions for installation very carefully, but the lights will NOT work on low beam. What gives? Any ideas or suggestions on how to get these lights working in low beam is greatly appreciated!
The HIDs are only working in high beam. Won't work at all in low beam. I want them to work in low beam.
04-28-2013 03:14 PM
leslie2012
Quote:
Originally Posted by Jeepin9910 View Post
Have you tried to flip the connector on the ballast around?
Yes. that was one of the first things I tried.
04-28-2013 02:59 PM
Jeepin9910 Have you tried to flip the connector on the ballast around?
04-28-2013 01:09 PM
leslie2012
HID lights not working on low beam

Hi All,

I need some help. I just purchased H4 HID kit from hidkitwarehouse.com for my 2003 Jeep Wrangler Sport. I followed the directions for installation very carefully, but the lights will NOT work on low beam. What gives? Any ideas or suggestions on how to get these lights working in low beam is greatly appreciated!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:32 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC