Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > '01 Hard Top Vents

Join Wrangler Forum Today


Thread: '01 Hard Top Vents Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-09-2013 10:53 PM
boydx6 Thanks
12-09-2013 07:59 PM
dcmtex I just replaced mine with factory. Pricey little devils. The foam ring around them had worn out. I had super glued them and that worked till I had a complete paint job on the jeep and top. They came apart thus the replacements. Shop after market if available.
12-09-2013 05:21 PM
boydx6
Quote:
Originally Posted by Gold Miner View Post
Quick question...
My '01 hard top vents are feeling loose. I haven't attempted to remove them.
Is there an OEM rubber seal there.... possibly deteriorated? Thy don't feel right.
Thanks!
Did you ever find out an answer to your vent problem? I just picked up a hardtop and the vents are really loose. I barely pulled on them and they came apart.
05-04-2013 06:40 PM
Gold Miner
'01 Hard Top Vents

Quick question...
My '01 hard top vents are feeling loose. I haven't attempted to remove them.
Is there an OEM rubber seal there.... possibly deteriorated? Thy don't feel right.
Thanks!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:57 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC