Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Build Forum > Jeep 1990 YJ nuttered,motorcraft no vacuum leaks won't idle runs crazy rich.

Join Wrangler Forum Today


Thread: Jeep 1990 YJ nuttered,motorcraft no vacuum leaks won't idle runs crazy rich. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-06-2013 10:14 AM
Jerricho Check the timing too, of it was not set right when it got Nuttered, or slipped it can cause a bad idle.
05-05-2013 10:44 AM
Nubby55 put a vacuum gauge on it and adjust the low speed needles, if that's not it check the power valve.
05-05-2013 10:34 AM
Beachcruiser I always like to start w/ the basics: compression test, basic electrical, etc. If you have poor compression, then it will be next to impossible to get it to run correctly.

You shouldn't have a rich condition w/ the new carb if it is set up right. The stock carters are notorious for plugging up & conking out at idle, but the MCs will idle down to 500, smooth as silk.

The ICM is a possibility, but they usually just go out.

Fuel pressure should be fine if you kept the return line to the tank (that bleeds off excess pressure).

Have you checked all the grounds in the engine bay? You may be getting a very weak spark at speeds not high enough to trip the alternator into charging. I'd freshen up all your contacts on the battery, cables & ground wires...especially the ones connected to the engine & charging system.
05-04-2013 06:46 PM
dovedude So next two things I am going to try are the icm and do a fuel pressure and ill update then. Any other help would be greatly appreciated. Thanks!
05-04-2013 05:07 PM
dovedude
Jeep 1990 YJ nuttered,motorcraft no vacuum leaks won't idle runs crazy rich.

Alright guys, just purchased a 1990 jeep YJ 4.2 with the 5 speed. It ran great in all gears but wouldn't hold an idle and died when I put the clutch in at stops. I tried the nutter..nothing. So I installed the motorcraft 2150 from the eBay guy with no change. Triple checked the vacuum lines and timing. Had a loose intake bolt fixed that. New plugs,wires,coil,cap still runs super rich and dies. The starter grinds sometimes when trying to fire and it sat for about a year. It does have exhaust leak at the donut i think as well. Any ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:30 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC