Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 2005 LJ cooling issues.

Join Wrangler Forum Today


Thread: 2005 LJ cooling issues. Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-21-2013 10:15 AM
HicksFromTheStix Thanks to everyone for their input and suggestions. We did find that the upper and lower radiator hoses needed to be replaced, as did the thermostat. My wife, before she left for our daughter's graduation, diagnosed it correctly by saying she didn't think the fan was turning fast enough. So after have numerous "mechanics" check it out, my wife ended up being the correct one. It was the fan clutch that had gone out. We flushed the system, and put G-05 coolant in it. She's running fine now. So if you're working on your rig, and your wife makes a suggestion, take my advice and listen.
05-15-2013 09:13 PM
Green LJRub Spray the mud out of your radiator with a hose! Haha
05-14-2013 03:56 PM
Jerry Bransford The factory specified thermostat is a 195 degree model, your computer & its programming will be much happier with that instead of the 180 presently installed. Not to mention a lower temp thermostat won't keep the engine any cooler when things get hot.

Also, make sure to never install a "fail safe" thermostat. They get stuck in the open position way too easily which means the engine won't warm up as quickly as normal which will keep the 02 sensor out of the loop which means less mpg & power.
05-14-2013 03:56 PM
UnlimitedLJ04
Quote:
Originally Posted by HicksFromTheStix View Post
Im using OReilly 50/50 mix. I just looked at it and its for older vehicles. That may be part of the problem. I also thought about just pulling the thermostat out. It may have gotten some debris in it. Thanks for your ideas.
Your Jeep needs HOAT coolant. Mixing other types of coolant with it will cause chemical reactions inside your cooling system, which will ultimately destroy the entire system.

here's more info:
HOAT Coolant Summary, and this video helps.

now that you've contaminated the system, you need to thoroughly flush it with distilled water, and start over using this procedure.

make sure the thermostat has a bleed hole, and will correctly bleed air from the system. also, the jeep should run at 195-210°F, 180 is actually too cold.
05-14-2013 03:50 PM
HicksFromTheStix Im using OReilly 50/50 mix. I just looked at it and its for older vehicles. That may be part of the problem. I also thought about just pulling the thermostat out. It may have gotten some debris in it. Thanks for your ideas.
05-14-2013 03:35 PM
Dextreme Somehow the water isn't flowing...so the thermostat is not opening or the impellor fins on the waterpump might be shot. Or you could have a blockage in the radiator.

What coolant grade are you using?
05-14-2013 02:50 PM
HicksFromTheStix
2005 LJ cooling issues.

Had my 4.0 start overheating this weekend. Found a bulging upper radiator hose, and replaced it. Have a 180 degree thermostat in it that was put in last summer. Coolant is topped off, dont have any answers. Checked water pump and no leaks, apars to be working fine. Jeep has 70k in miles. Any suggestions?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:01 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC