Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > Z10 BB problems with Uconnect

Join Wrangler Forum Today


Thread: Z10 BB problems with Uconnect Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-22-2013 10:27 AM
xsdbs There are 3 different suppliers for the Uconnect system. Depending on which radio that you have, you're correct about Uconnect being an external module. Radios REQ, RES, RBZ & RHB all have an external module while the 730 & 730N have internal Uconnect. So in the case of the OP, his radio SW update would also have the Uconnect SW in it. The other listed radios would have separate SW versions for the radio & Uconnect.
Now because there are 3 different mfg's for the Uconnect, several different SW writers and the fact that the BT specs aren't tightly regulated this leaves the specs to be interpreted differently by each SW writer. This leaves the door wide open for a phone to work with some radios but not others. Of course this isn't only with the Chrysler Uconnect system. It's true with other vehicle mfg's as well. Where a phone may work with Chrysler but not a different vehicle mfg.
There was an issue with the first released BB Z10 phones and the way the phonebook contact info was being sent from the phone when pairing, but BB released an update for this phone a short while back.





Quote:
Originally Posted by supercazzola View Post
I'm not 100% sure, but it seems uconnect module is separate from radio. So when you upgrade firmware on radio, it actually changes the way the s/w interfaces between the radio and the uconnect module. But wouldn't the s/w on the uconnect module not change? Unless they flash the module for uconnect? I've seen intermittent issues with multiple devices on my vehicle, even when I swapped out a RES radio for a new RBZ. What stayed the same? The uconnect module. So not sure how flashing the radio would fix a design flaw with uconnect. It could only patch how the radio talks /interfaces to the module.
Just my thought, but after swapping out radios, I'm gonna stick with my hypothesis.
05-22-2013 07:37 AM
supercazzola I'm not 100% sure, but it seems uconnect module is separate from radio. So when you upgrade firmware on radio, it actually changes the way the s/w interfaces between the radio and the uconnect module. But wouldn't the s/w on the uconnect module not change? Unless they flash the module for uconnect? I've seen intermittent issues with multiple devices on my vehicle, even when I swapped out a RES radio for a new RBZ. What stayed the same? The uconnect module. So not sure how flashing the radio would fix a design flaw with uconnect. It could only patch how the radio talks /interfaces to the module.
Just my thought, but after swapping out radios, I'm gonna stick with my hypothesis.
05-22-2013 07:22 AM
xsdbs I have a friend that has the Z10 and it works well with his 730N. What SW do you have on the phone? His is:
10.0.09.2372




Quote:
Originally Posted by hhz View Post
Anyone having trouble with Uconnect with new Blackberry Z10 phone? My 2012 Wrangler with 730N nav unit will not recognize the phone with BT discoverable turned on, nor will the phone recognize the Jeep. Jeep connected fine to prior BB 9700 and new Z10 connects to my other vehicle and BT earpiece. Jeep website says I have latest software for the 730N. I'm stumped.
05-10-2013 09:25 PM
hhz
Z10 BB problems with Uconnect

Anyone having trouble with Uconnect with new Blackberry Z10 phone? My 2012 Wrangler with 730N nav unit will not recognize the phone with BT discoverable turned on, nor will the phone recognize the Jeep. Jeep connected fine to prior BB 9700 and new Z10 connects to my other vehicle and BT earpiece. Jeep website says I have latest software for the 730N. I'm stumped.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:10 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC