Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Power Window Issues

Join Wrangler Forum Today


Thread: Power Window Issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-05-2014 02:50 PM
mattdenney07
Quote:
Originally Posted by SilverSport View Post
Welcome Aboard! Perhaps this will help.
Sorry to bump an old thread, but this helped me out a ton. SilverSport, where did you get this wiring diagram? Also, are there diagrams like this for more systems in the JK? They need to be made public if they exist!
05-24-2013 07:09 PM
SilverSport Welcome Aboard! Perhaps this will help.
05-24-2013 04:06 PM
Deuble
Power Window Issues

The rear driver's window in my 2008 Jeep Wrangler Unlimited will roll down but now back up. The front switch does not work for that window at all (it works fine for the other three) and the back switch will roll the window down but not back up. I have tried the turn it off and then turn it back on again trick and that doesn't work. I have also reset the ecu and that did nothing. If I connect a 12v power source directly to the motor the window will roll back up so it's not the motor. I've been for two weeks now trying to figure this out. Any help would be greatly appreciated!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:49 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC