Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > Off Road and External Lighting > KC Lights wiring question

Join Wrangler Forum Today


Thread: KC Lights wiring question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-16-2013 06:20 PM
wat3rdog I bought the KC highlights and their rep said that I need a relay for mine since they draw so much power. He was nice enough to tell me what diagram to use and what kit that they offer for it. Good customer service. Maybe you should shoot them an email.
06-16-2013 06:15 PM
Kingcat Bc3_jeep please explain how relays are a bad idea for this application? How would you wire them?
06-16-2013 05:29 PM
wat3rdog Please post what the issue is when you figure it out. I am getting ready to install my first set of KC's that I bought used.
06-16-2013 01:25 AM
Always JK'n I'll try that out tomorrow! Thanks!
06-08-2013 08:57 PM
bc3_Jeep Take 12 Volts straight from the battery to each light and see if it works that way. If not, suspect a ground issue with lights (possible issue with grounding point such as windshield frame not uncommon).

If they work straight from battery, odds are you are on the incorrect relay terminals for relay activation OR for relay to power lights. This is not possible, since you wired them correctly..... so you must have a bad relay.

I, for one, do not think relays are a good idea in this kind of application, but MANY others will disagree.
06-08-2013 07:47 PM
Tweak are you sure the wires on the underside of the switch are correct? if you are getting a light on the switch you have a good ground.
06-08-2013 04:27 PM
Always JK'n
KC Lights wiring question

Just purchased and wired 2x new driving lights to mount on the lower corners of the windshield.

I wired correctly, but cannot get the lights to turn on. I've tried multiple different locations for the ground from the relay, and multiple locations for the white wire (fuse, battery), but still no luck.

When I have the battery on, the LED on the switch itself turns on, but nothing from the lights...anyone have a possible remedy for this?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:03 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC