Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Traction/drifting HELP!

Join Wrangler Forum Today


Thread: Traction/drifting HELP! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-09-2013 03:58 PM
slevane Check that tire pressure when I bought my '06 the previous owner had the tires at 55lbs! I hit some rain on the the road a few days later and it was like trying to drive on ice. I chalked the tires and the contact patch was just in the very middle of the tire. Currently running happily at 32lbs with a nice smooth ride and plenty on traction.
06-09-2013 12:13 PM
Jodfie I'm currently at work but will inform everyone when I'm off and home
06-09-2013 11:57 AM
Jerry Bransford
Quote:
Originally Posted by Jodfie View Post
Sorry no lift tires at normal listed pressure on tire(forgot what it is)
The pressure molded onto the tire's sidewall is never the correct pressure to actually run, that is only the tire's maximum safe pressure to only be used when the tire is forced to carry its absolute maximum load. What pressure is in your tire & what size is it?
06-09-2013 10:58 AM
wa_troop
Quote:
Originally Posted by Jodfie View Post
Ok so I've had my 01 TJ 5spd w/o ABS for awhile now when I bought it...it had cheap mud terrains from pep boys that had basically noting left on them...they were very loud but still had remarkable road traction(like not drifting while cornering or spinning tires at a light when on a wet road) now I have basically new wrangler duratracs and it slides all over e place when it's wet out!...I was told they have amazing traction though...is it my driving or is it something mechanical I need to look at? And if its my driving what am I doing wrong?
Lift it some you'll get more body roll won't slide out as easy lol I uses to go around drifting In my jeep until I lifted it now its hard to get sideways on gravel haha
06-09-2013 10:51 AM
wellbuilt My duratracks seem fine, im down to 1/3 tread and they are a little slippy now .
I run 30 front 27 rear on 31 10. 5s .
06-09-2013 10:40 AM
Rubicondon53 The listed tire pressure is not a good thing to go by.. Each time I've had new tires, (many many times) the shops always put the max recommended pressure in... You should have no more than 36 lbs, and no less than 30 lbs, depending on the weight you are carrying... Cruising around I run 32 lbs,,, loaded up with camping gear and trailer I run 32 up front and 36 in the rears..
06-09-2013 09:58 AM
Jodfie Sorry no lift tires at normal listed pressure on tire(forgot what it is)
06-09-2013 09:54 AM
speedyrev How about some more info about your setup? Lift? What's your tire pressure?
06-09-2013 09:43 AM
Jodfie
Traction/drifting HELP!

Ok so I've had my 01 TJ 5spd w/o ABS for awhile now when I bought it...it had cheap mud terrains from pep boys that had basically noting left on them...they were very loud but still had remarkable road traction(like not drifting while cornering or spinning tires at a light when on a wet road) now I have basically new wrangler duratracs and it slides all over e place when it's wet out!...I was told they have amazing traction though...is it my driving or is it something mechanical I need to look at? And if its my driving what am I doing wrong?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:27 PM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC