Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Electrical Problems?

Join Wrangler Forum Today


Thread: Electrical Problems? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-02-2013 08:32 PM
blade4804 Thread jack... I noticed my airbag light come on and off, radio works fine, I didn't check wipers/horn yet. Howler while the airbag light is on the speedo and odometer drop to 0. Is this also clock spring?
07-20-2013 10:52 PM
dakotaTJ
Quote:
Originally Posted by CommissionerGordon View Post
So today I went to drive my jeep and when I started it the airbag light came on and wouldn't go off. Also, while I had the jeep running my blinkers and windshield wipers wouldn't work. Does anybody know why this would happen or what I could do to fix it?

Thanks!!

Another way to tell if it's the clockspring, is if you have cruise control and it also is not working. I have a bad clockspring I am going to replace in my 99 TJ, and the horn and cruise don't work. The airbag light also stays on all the time.
07-20-2013 08:07 PM
Maury Moseley
Quote:
Originally Posted by Water Dog View Post

If you bought it from a dealer, try taking it back and get them to fix it...! The clutch noise is likely the throw bearing = pulling the transmission and replacing the clutch. The brake light indicates (possibly) that only half your brakes are working, front or back, and the air bag light could be the clock spring (as above) or some other malfunction.
The funny thing is, when i turn off jeep and it cools off, all of the symptoms go away......until its driven for enough time for it to heat up...........
07-20-2013 07:50 PM
Water Dog
Quote:
Originally Posted by Maury Moseley View Post
Ok, i just purchased a 2000 TJ, within a few miles, i get this...........
Air bag light, brake light stuck on....radio out..... And when i put in clutch completely i get a grinding noise that sounds like starter engaging, but only when clutch depressed fully, let it out some and that noise stops.........i am stumped!
If you bought it from a dealer, try taking it back and get them to fix it...! The clutch noise is likely the throw bearing = pulling the transmission and replacing the clutch. The brake light indicates (possibly) that only half your brakes are working, front or back, and the air bag light could be the clock spring (as above) or some other malfunction.
07-20-2013 06:05 PM
Maury Moseley Ok, i just purchased a 2000 TJ, within a few miles, i get this...........
Air bag light, brake light stuck on....radio out..... And when i put in clutch completely i get a grinding noise that sounds like starter engaging, but only when clutch depressed fully, let it out some and that noise stops.........i am stumped!
07-18-2013 07:49 PM
Big Sarge
Quote:
Originally Posted by JeepGirl94 View Post
Thanks
You bet ya!
07-18-2013 07:20 PM
JeepGirl94 Thanks
07-18-2013 07:13 PM
Big Sarge
Quote:
Originally Posted by JeepGirl94 View Post
Sorry to hijack the thread. But we just bought a 97 wrangler Wednesday and the horn does not work and the air bag light is on. The PO or dealership installed a button on the dash for the horn which is a big pita. What is a clockspring and where is it located? Thanks!
Here ya go

http://www.wranglerforum.com/f5/airb...ml#post1267523
07-18-2013 06:55 PM
JeepGirl94 Sorry to hijack the thread. But we just bought a 97 wrangler Wednesday and the horn does not work and the air bag light is on. The PO or dealership installed a button on the dash for the horn which is a big pita. What is a clockspring and where is it located? Thanks!
06-19-2013 10:39 AM
Big Sarge
Quote:
Originally Posted by Wattapunk View Post
Usually clockspring issues would involve the airbag light on along with no horn. So if your horn is out, I would look into the clockspring but if not then I am more incline to think you have a faulty ignition switch since you are getting intermittin no power to the wipers and turn signals. I would get a multitester and check the voltage at the ignition switch in various positions. Try jiggling the switch next time the issue occurs.
Original post Had complaints of illuminated airbag light as well
06-19-2013 10:24 AM
Wattapunk Usually clockspring issues would involve the airbag light on along with no horn. So if your horn is out, I would look into the clockspring but if not then I am more incline to think you have a faulty ignition switch since you are getting intermittin no power to the wipers and turn signals. I would get a multitester and check the voltage at the ignition switch in various positions. Try jiggling the switch next time the issue occurs.
06-19-2013 07:44 AM
CommissionerGordon
Quote:
Originally Posted by MOTO X TJ View Post
X2 Check the horn too....if its out, I would imagine it is the clock spring.
Everything has been fine up until the past few days. However, I noticed it only happens in the mornings. If I go a tart it during the day it's perfectly fine but in the morning is when it messes up constantly.
06-11-2013 08:35 PM
MOTO X TJ X2 Check the horn too....if its out, I would imagine it is the clock spring.
06-11-2013 07:03 PM
Big Sarge
Quote:
Originally Posted by CommissionerGordon View Post
So today I went to drive my jeep and when I started it the airbag light came on and wouldn't go off. Also, while I had the jeep running my blinkers and windshield wipers wouldn't work. Does anybody know why this would happen or what I could do to fix it?

Thanks!!
Probably the clock spring. Hope that helps you out.
06-11-2013 06:40 PM
CommissionerGordon
Electrical Problems?

So today I went to drive my jeep and when I started it the airbag light came on and wouldn't go off. Also, while I had the jeep running my blinkers and windshield wipers wouldn't work. Does anybody know why this would happen or what I could do to fix it?

Thanks!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:51 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC