Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Squeeeeel

Join Wrangler Forum Today


Thread: Squeeeeel Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-15-2013 06:25 AM
bruceandjo95yj Thanks for the replies
I have checked the "play" in the tire by trying to shake it and there is none.
I did bleed the air out but will try it again just to make sure.
And I'm getting ready to grease everything now lol.
06-14-2013 11:32 PM
jfbilbro if it's doing the squealing when you turn either direction, it sounds like air in the power steering system...i saw the pump was new....did you bleed the air out after installing the pump?
06-14-2013 08:38 PM
overthehillsahara Have you checked hub bearings. With the tire in the air check it sisde to side and up and down.
06-14-2013 08:12 PM
jokerchief462 Try the front axle u-joints
06-14-2013 06:50 PM
Redrider94 Have you greased the ball joints and tie rod ends?
06-14-2013 04:12 PM
bruceandjo95yj
Squeeeeel

There is a squeal when I turn a corner,it doesn't matter which direction.
...it also doesn't matter the speed...fast or slow..
I was thinking hubs..but I asked my dad who is a little more of a mechanic than me and he said it doesn't sound like hubs to him..also said it would be highly unlikely that both would go at the same time.

Background on my jeep,95 i6 5 speed
Brake pads are less than a year old.
Rotors are not new,calipers are new.
lines are all new front and back.
the frame from the trac bar forward is new.
power steering pump is new.
also with the jeep in the air,when i turn the tires by hand..there is resistance...like it doesn't want to turn.also when i turn it theres a noise like metal to metal and dirt in it..doesn't turn freely..but there is no play when I shake the tires...hands up/down or forward/backwards.
This has got me stumped,could really use you guys help
Thanks in advance.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:20 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC