Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Help

Join Wrangler Forum Today


Thread: Help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-17-2013 01:07 PM
Nubby55
Quote:
Originally Posted by allmudd View Post
with the engine off try and shake the exhaust as much as you can and see if it rattles. Your cat might be clogged causing lack of power. And the shifting thing if it was good then got worse i would say your system is getting air in it. You might have a bad cmc or csc.

x2
06-17-2013 01:44 AM
AllMudd With the engine off try and shake the exhaust as much as you can and see if it rattles. Your cat might be clogged causing lack of power. And the shifting thing if it was good then got worse I would say your system is getting air in it. You might have a bad CMC or CSC.
06-16-2013 11:22 PM
Tracy93 Lack of power as in going up steep hills i have to drop it in second. And the clutch situation i bleed it today and it ran fine down shifted fine until i went on rough road then it started messing up again. When i rebuilt it i also noticed that the front passenger motor mount was completely busted. Alot of people r telling me the motor might b moving causing bad shift problems not sure if that could do it or not? And i also have small crack in exhaust manifold so im thinking that it could b loosing power that way any more ideas ?
06-15-2013 11:46 PM
AllMudd Lack of power like wont go over 30-40? And not down shifting your tranny is bad. The synchros are done for. The AX5 is notorious for failing. Most people swap it out for the AX15.
06-15-2013 10:01 PM
Tracy93
Help

I need help i recently bought a 93 jeep wrangler. When i bought the jeep it lacked power its a 4cylinder but it was missing something so i rebuilt it and it still is lacking power any ideas. 2 nd problem also when i bought the jeep the dealership said it needed a new clutch so i replaced that also and it goes in all gears fine but wont let me down shift at all it just grinds really bad even when completely stopped i cant get in 1st gear till i shut it off please ideas im running out of options thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:21 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC