Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Losing power

Join Wrangler Forum Today


Thread: Losing power Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-17-2013 07:54 PM
BlakeDuke123 That's a lot cheaper than what I got charged for my truck lol
06-16-2013 08:46 PM
cfarlow89 took mine to a shop. they charged $150 for the part and labor. Just throwing that out there.
06-16-2013 08:38 PM
BlakeDuke123 Ok thanks. Will check into replacing it
06-16-2013 08:29 PM
cfarlow89 catalytic converter X3

just replaced mine. Had exact same problems. Loss of power and a nasty burning smell.
06-16-2013 07:48 PM
Tomdata
Quote:
Originally Posted by jp2611 View Post
cat...best guess ..................sluggish and gets worse...cat swells when hot from running...cools down less restrictive...as i said just a guess based on my experience.
x2
06-16-2013 07:29 PM
jp2611 Cat...best guess ..................sluggish and gets worse...Cat swells when Hot from running...cools down less restrictive...as I said just a guess based on my experience.
06-16-2013 07:27 PM
BlakeDuke123
Losing power

Having problem with jeep losing horse power once it warms up. Gets a burning smell. Any ideas on what could cause this? It's fine after its been sitting awhile

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:25 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC