Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Fuel System GTG, what about Tranny throttle linkage??

Join Wrangler Forum Today


Thread: Fuel System GTG, what about Tranny throttle linkage?? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-25-2013 10:02 PM
JimboYJ Joker,

Thanks for the input. I'll check out the drive shaft. It's in pretty bad shape. Probably wouldn't hurt for some new u-joints or even a whole knew shaft.

Jimbo
06-25-2013 10:29 AM
jokerchief462 The exhaust manifold stud(s) need to be fixed for sure and yes they will play hell with the O2 sensor. I have never had an auto tranny squeal or squek on take off or acceleration it may be a driveline issue u joints maybe they will squeek when rusted or shot.

As far as the throttle linkage to the tranny IMHO I wouldn't think it would cause a surge when driving. It is more likely the ECU cycling the fuel air mixture based inputs.

This is a tough one and I know an auto tranny is always suspect and when they are old. But I think its engine related for the surge and the squek has to be driveline.
06-24-2013 08:17 PM
JimboYJ
Fuel System GTG, what about Tranny throttle linkage??

Hey everybody,

Still having "surge" issues in my 95YJ 2.5, auto trans. I recently aquired this new project and the PO did not treat her well under the hood. I have a surge problem when I'm around 1500-2500 RPM. I can mash the accelerator and it will downshift fine and also taking off from stoplights is OK. It's only when I'm cruising along around 25-35 MPH and I try to give it some go-go it starts surging. I have spend hours on here reading hundres of posts and got some great info. Here's what I have done so far: Replaced TPS and checked it electrically - it's good. Replaced spark plugs (properly gapped now....don't ask.....f-in PO!!!) and verified good spark at all four. New fuel filter. Conducted complete fuel system pressure/capacity tests and everything checks out in spec. I have two potential problems that I can see and was looking for some advice. First off I have some broken studs on my exhaust manifold. Could this be causing a substantial air leak and messing up the O2 sensor?? Second, I've been reading up on the throttle linkage to the transmission. Does anybody have any experiences to share about adjusting these hard to reach gems? Just curious. I also have a slight squeaking sound when I first take off from a stop. More and more I'm thinking my transmission just might be jacked up. Trying to troubleshoot my way out of a new tranny. Any thoughts/advice would be great.

Jimbo

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC