Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > DTC P06dd Anyone else?

Join Wrangler Forum Today


Thread: DTC P06dd Anyone else? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-28-2013 12:09 PM
aypanthony
Quote:
Originally Posted by aypanthony View Post
Anyone else get this error code?

P06DD-DUAL STAGE OIL PUMP STUCK LOW

Looks like it could be a bad oil filter(I used NAPA Gold), a bad sending unit or a bad oil pump.

Just curious if others have had this issue. I am getting ready to take my jeep on a cross country trip(starting Tuesday) and don't need this right now.
Update: Dealership called me and indicated that it is probably the Napa Gold oil filter I used. Because of this, they are going to charge me the diagnostic fee.

I told them install the Mopar oil filter and do the diagnostic/oil pressure checks as specified in their STARS system. I am not convinced it is the NAPA Gold oil filter, since that is what I have used in the last 4 oil changes, but we shall see.
06-27-2013 08:58 PM
aypanthony
DTC P06dd Anyone else?

Anyone else get this error code?

P06DD-DUAL STAGE OIL PUMP STUCK LOW

Looks like it could be a bad oil filter(I used NAPA Gold), a bad sending unit or a bad oil pump.

Just curious if others have had this issue. I am getting ready to take my jeep on a cross country trip(starting Tuesday) and don't need this right now.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:11 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC