Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Need Someone to Blow Taps for my Dead SE

Join Wrangler Forum Today


Thread: Need Someone to Blow Taps for my Dead SE Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-01-2013 10:32 AM
Holton345
Quote:
Originally Posted by MississippiDirtTJ View Post
Time for some V8 power
Oh, yes. I cannot do this for some time. But I AM going to do it for sure at some point!
07-01-2013 07:23 AM
MississippiDirtTJ Time for some V8 power
06-30-2013 07:38 PM
Holton345
Need Someone to Blow Taps for my Dead SE

I got my dead 2.4L SE home today after a pretty sketchy 75 mile long tow home with improper gear and straps. (They were the best we could do on shot notice. And they worked.)

I have been working on the Sport since I got it. The CEL is now OFF. I hope the Jeep Gods deign it worthwhile to KEEP the dang thing off for a looooong time.

The 13 MPG is now up to an average of 16 with short state highway runs of about a half an hour (at 55 to 60 mph) where we are getting just a hair above 20 mpg. Daddy is pleased, to say the least.

The TC linkage now works properly and I have all four settings engaging and disengaging nicely, no popping out, no halfway positions, etc.

To get the CEL off I had to have all four O2 sensors replaced. The six rather tragic spark plugs also were tossed for new ones. The badly installed, plugged up and hole-filled cold air intake system was chucked for a completely stock one. I cleared the codes and dumped the memory so that the engine reset to factory defaults. Then I had to start up cold and drive a few times. After that the temp dropped to 210 and the CEL turned off.

The little 2.4L SE is now home from the dealership where is has sat since May 11th when it threw a rod through the rear of the block. The tow home was a perfect example of what could be termed a misadventure. But we only loosened the rear bumper of my jeep a bit, what with all the damned slack being snapped straight by my wife for 75 miles. (God bless her, but she does NOT know how to drive a car being towed through turns, braking and acceleration. She does now, but my poor rear bumper mounting bolts!!!)

Here are both of them, side by side in my carport. Thank God this mess is over. I have wheels again and the burden of having a dead vehicle on a lot 75 miles away is ended.

Now I have two paid-off jeeps, with the motor-less one in great physical shape, ready for an engine swap and a long arm lift...


Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:19 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC