Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > So here's the dealio...

Join Wrangler Forum Today


Thread: So here's the dealio... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-02-2013 11:00 PM
Bravo.Justin Just a suggestion for any of you guys having similar issues, but it may be worth at least pulling the O2 sensors...
06-27-2013 10:23 PM
Bravo.Justin So here are the old mini cats. As you can see in the first pic, the cat is COMPLETELY blown out. I have never seen this happen before. This is why I am throwing the bank 2 downstream code. My downstream O2 sensor was bent, which led me to believe that the cat was falling apart.
06-06-2013 01:12 PM
Rwill8751 I hate mud too
06-06-2013 01:08 PM
Bravo.Justin Yeah I tightened mine too in hopes that the problem would go away. It was fairly loose. Once I grabbed some extensions and universal joint adapters it was cake.

I had ZERO problems with my jeep until an annual mud ride about 2 months ago. Since then, brakes have locked up, engine started overheating, catalytic trouble, etc. I HATE MUD!
06-06-2013 12:42 PM
vwlos I had the P0432 code, which is "bank 2 cat efficiency below threshold". Someone suggested that I try tightening the downpipe to the manifold since it was a bit loose...but that did not resolve the problem. After that, I decided to bite the bullet and buy the new "direct fit" downpipe with all 3 cats, a new cat back dynomax muffler, and 2 new downstream O2's.

I see you're in AL, and if your rig has lived it's entire life in the southeast like mine, then hopefully your downpipe will unbolt from the manifold as easy as mine did....once I got the right sockets to access all 4 of the nuts.
06-06-2013 12:20 PM
Bravo.Justin Those are very good points. I guess my philosophy was to go with an upgraded high flow since I'm gonna have to shell out the dough for a new system anyway. Was gonna replace the cats and muffler all at once. I don't think the bank 2 mini is completely gone yet, but I can tell its close. The downstream O2 sensor was even bent (the internal sensor itself) when I pulled it out. Pretty sure the cat is falling apart slowly and clogging the main. Vwlos, did you have the same issue, or how'd you determine it was the cat?
06-06-2013 12:00 PM
vwlos I replaced the entire exhaust system on my 04 Rubicon back in February. The mini cat on bank 2 had completely blown out and clogged the big cat resulting in one of the same codes you mentioned above. Instead of buying a single mini replacement cat and having to cut off the bad one and weld in a new one (which I couldn't do myself since I have zero welding skills), I bought the "direct fit" kit from rockauto. My logic was "might as well replace all 3 at once...because knowing my luck the other original one would fail shortly after". As far as the high flow cats go, I personally don't see the importance or need on a Jeep....It's kinda like putting a cold air intake on....why bother??
06-06-2013 11:46 AM
jeepwayoflife As far as what cats to get, I personally would just go OEM just because I don't know the quality of aftermarket cats. Stock ones go easily over 100,000 miles. The high flow ones will cost more and won't help too much other than allowing the engine to breathe a little better and it will be a little louder. If you get high flow cats you would want high flow exhaust too. Its kind of a big chain of things to get the performance enhancement you expect from upgrading the cats. Also, many engines require back pressure to work properly. I wouldn't think high flow cats would effect this but does anyone have experience with that?
06-06-2013 11:42 AM
Bravo.Justin Yeah the 04 has the two mini cats and the main. The entire down-pipe bolts up so shouldn't have to replace the header unless its cracked. Sensors are on the down-pipe just in front and behind the minis. To clarify, I have replaced the downstream bank 2 sensor, and I'm still getting the same code(s). I'm fairly confident that it's the cat because of the lack of power and performance, smell, and same code. Was wondering if it could be the upstream sensor as well. I'm really just looking for opinions on a high flow cats. Or should I stick with OEM style from rockauto?
06-06-2013 05:09 AM
joebarlow65 When you say you've narrowed it down to a bad cat how did you do so? Did you test both sets of o2 sensors? Unfortunetly until you test them and get a definitive result you will be changing parts and hoping for the best. Im not sure what exhaust the 04s had but my 06 has 3 cats. Two in the header, and one right in front of the muffler. My sensors are around the header ones and swapping them out would require a new header, or cutting and welding. I would still say its your o2 sensors because they would make your air/fuel go screwy, and sensors typically go bad faster than hard parts. It could be the upstream one that's bad as well and makes the down stream look incorrect.
06-05-2013 10:39 PM
Bravo.Justin
So here's the dealio...

I've scoured the forum and researched until I'm blue. Now I need some opinions from you fine gents. My 04 rubicon keeps throwing code P0432 and OCCASIONALLY P0123. I've tightened the manifold (which was loose) and cleaned the downstream bank 2 sensor. Cleared the codes several times, but comes back within a day or two. I've pretty much narrowed it down to a bad cat. The problem:

Today is the first time I've noticed a lack of power at all. It also threw P0123 today, when normally it's just P0432. Would the cat affect the throttle position sensor, or do I need to replace it as well? I've had some sporadic engine hesitation after the 0432 code has been then thrown, but I think it may have been the ECU acting crazy because of the misreadings. It always goes away after I shut the engine off and restart.

The main question:

For those of you that have replaced your cats, which brand did you go with? I've read about a few of you guys going with a high flow cat, which is what I'd like to do. However, I obviously don't want to keep throwing a CEL. what's the best bang for the buck that is compatible? Thanks in advance fellas.

P.S. Sounds like the cat and not the O2 sensor, right...?? I don't want spend 80 bucks on one if it's the cat all along.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:09 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC