Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > KC Lights not bright

Join Wrangler Forum Today


Thread: KC Lights not bright Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-15-2013 05:33 AM
Neil F.
Quote:
Originally Posted by LBIHUI View Post
Ok, so I stripped out all of the wiring. I replaced with larger gauge wiring (12) and wired in parallel. Now the lights are working very well with adequate brightness. Thanks for all the help!

Any suggestions about the condensation in the light? Per KC this is "not uncommon" but I would still consider this to be less than ideal. SHould I take the light apart, dry it out, and reseal the light? Any other suggestions?

Mike
Open it up and dry it. If the rubber seal is rotted/cracked, call KC. All the parts (including bulbs) are warrantied for 23 years.
07-13-2013 09:15 PM
Water Dog
Quote:
Originally Posted by LBIHUI View Post
Ok, so I stripped out all of the wiring. I replaced with larger gauge wiring (12) and wired in parallel. Now the lights are working very well with adequate brightness. Thanks for all the help!

Any suggestions about the condensation in the light? Per KC this is "not uncommon" but I would still consider this to be less than ideal. SHould I take the light apart, dry it out, and reseal the light? Any other suggestions?

Mike
Glad you got it worked out Mike. Using too small of wire is like us two fat people trying to squeeze through the door way at the same time...not very bright..! Sorry, old person joke . Not sure about the condensation. My guess is that maybe if you left them on for awhile, maybe the heat would take care of it...just don't know.
07-13-2013 08:41 PM
LBIHUI Ok, so I stripped out all of the wiring. I replaced with larger gauge wiring (12) and wired in parallel. Now the lights are working very well with adequate brightness. Thanks for all the help!

Any suggestions about the condensation in the light? Per KC this is "not uncommon" but I would still consider this to be less than ideal. SHould I take the light apart, dry it out, and reseal the light? Any other suggestions?

Mike
07-12-2013 10:38 AM
Water Dog
Quote:
Originally Posted by LBIHUI View Post
Does anyone know if the wiring harness from KC is wired in series or parallel? From the diagram provided by KC and posted by Water Dog seems to be series but then again I could be wrong.
The diagram I posted is wired in parallel.
If you have a multi meter, you can check the hot to ground voltage at each light (with the lights still wired and on). They each should be 12+ volts. If they are around half of that, you most likely have them wired in series. If they are somewhere between 6 and 12, you probably have voltage drop due to high amperage in too small of wires or bad grounds, or both.

I'll add that bad connections can also cause this problem. Like the connections from the harness to the lights themselves, or any other place where they may have made connections.
07-12-2013 09:36 AM
Jerry Bransford If installed per the directions, the KC harness would correctly wire the lights in parallel but I never assume anything so far as how some installers might change a few things around without knowing the consequences.
07-12-2013 09:31 AM
LBIHUI
Quote:
Originally Posted by Jerry Bransford View Post
Wiring the lights in series with each other, that is the power passing through one light to the other, will make the lights burn at half brightness. Make sure both lights are connected independently to the power source so they're both receiving the full 12 volts.

Wiring the two lights in series with each other would mean each light is only seeing 6 volts instead of the required 12 volts.

The below lights on the left are wired in parallel and each light sees the full 12 volts so they are all at full brightness. The lights on the right are wired in series which divides the 12 volts between them so each of the 3 bulbs in the drawing is only seing 4 volts & are thus much dimmer. The drawing in post #11 above shows the lights correctly wired in parallel with each other.
Does anyone know if the wiring harness from KC is wired in series or parallel? From the diagram provided by KC and posted by Water Dog seems to be series but then again I could be wrong.
07-12-2013 09:17 AM
Jerry Bransford Wiring the lights in series with each other, that is the power passing through one light to the other, will make the lights burn at half brightness. Make sure both lights are connected independently to the power source so they're both receiving the full 12 volts.

Wiring the two lights in series with each other would mean each light is only seeing 6 volts instead of the required 12 volts.

The below lights on the left are wired in parallel and each light sees the full 12 volts so they are all at full brightness. The lights on the right are wired in series which divides the 12 volts between them so each of the 3 bulbs in the drawing is only seing 4 volts & are thus much dimmer. The drawing in post #11 above shows the lights correctly wired in parallel with each other.
07-12-2013 08:53 AM
sparky You said you ran the ground back to the battery. Which ground, from the relay or the one for the lights. Make sure the lights have a ground circuit directly back to the battery. Wire should be the same size as the feed. Don't rely on the mounting to the bumper/light bar as a sufficient ground, it usually is not.
07-12-2013 08:40 AM
MFsoftball22 Ok, Mounting the light upside down shouldnt make a difference as the housing should be sealed. Is the seal around the glass and the light cover still in place? How about the wire inlet seal?

Also I would need to see a pic of how bright they shine at night and not so close to the light. You have the Driving Lenses which are pretty bright but they are not the same as Long Range Lenses if that is what you are looking for. Driving Lenses should perform about like normal high beams on a car slightly better. Another thing is that the pole holder attached to your bumper is blocking some of the light beams which is going to restrict how they shine.

If you think that they are not burning as bright as they should be, Then take some wire and connect them to the light and put them directly to the battery, short time just to test them. (no switch, no relay, etc.) Then you can see if there is a difference in how bright the lights are shining. This way the power is going straight to the light.

Maybe look at these things and then see what you come up with.
07-12-2013 06:36 AM
LBIHUI Hooking up to the battery directly did not do anything to help the situation. My next step is the completely re-wire them again. I do not have the original harness intact any longer... Anyone know where I can get one at a reasonable price? Also, I noticed yesterday that one of the lights now has condensation inside. Anyone have experience with this? They are mounted upside down on a light bar. Should I drill a drainage hole? Any thoughts?

http://kchilitesnotworking.shutterfly.com/
07-11-2013 01:02 PM
Water Dog Here's a diagram of what your wiring should look like. The wire colors aren't that important, but the right size for the application is critical for full brightness. The wire for the 25 amp part of the circuit should be 12 gauge, which could also be used on the 10 amp portion. The wiring on the 3 amp (switch side) could be much smaller 16 or 18 gauge.
07-11-2013 12:25 PM
MFsoftball22
Quote:
Originally Posted by LBIHUI View Post
Thanks again. I will definitely make this change and let you know how it goes.

The shop I brought it to for the install ended up being a rip-off and I should have just done it myself from the beginning... ugh. Thats what you get for trying to save time - FRUSTRATION!

Mike
It's always better to work on it yourself. Makes you closer to your Jeep.
07-11-2013 11:46 AM
LBIHUI Thanks again. I will definitely make this change and let you know how it goes.

The shop I brought it to for the install ended up being a rip-off and I should have just done it myself from the beginning... ugh. Thats what you get for trying to save time - FRUSTRATION!

Mike
07-11-2013 11:43 AM
InvertChaos
Quote:
Originally Posted by MFsoftball22 View Post
I would def recommend using the wiring/relay/switches provided by KC. I used them for mine and it was simple with no problems. I would also try connecting the lights directly to the battery terminal. Im not sure if this makes a difference in this case, but had a 2001 Dodge Ram and tried connecting lights for the fuse box and made the truck run like crap and lights barely worked. It might be worth a shot to see if this would solve your problem.
This is good info. There is no way I would ever pull power for those lights from a fuse box. That is a ton of amperage being pulled by those lights. How it should be installed is that the lights get power from a relay which is connected directly to the battery. A switch also powered by the battery activates the relay.
07-11-2013 11:39 AM
MFsoftball22 I would def recommend using the wiring/relay/switches provided by KC. I used them for mine and it was simple with no problems. I would also try connecting the lights directly to the battery terminal. Im not sure if this makes a difference in this case, but had a 2001 Dodge Ram and tried connecting lights for the fuse box and made the truck run like crap and lights barely worked. It might be worth a shot to see if this would solve your problem.
07-11-2013 11:30 AM
LBIHUI I am sorry for the confusion. I was writing from memory and obviously it was not correct.

First off, thanks for all the suggestions and support.
To answer the questions:

The lights:
KC HiLites Daylighters Driving Lights
Daylighter Pair Pack System - Black12v130 watts / 175,000 candlepower


The wiring:
I actually had them professionally installed using the wiring harness provided, although the wiring harness was for a different set of lights that I then replaced with the KCs. They told me the problem was the ground and ran the ground back to the battery but the power is still coming from the fuse box as I stated. I am now thinking that I will replace the current relay with the one provided with the KCs. Does anyone think that will help?

Also, to clarify there are 2 KCs wired currely.

Thanks again!!
07-10-2013 06:50 PM
Neil F. Exactly what lights do you have? KC does not have 180w. (they don't offer the 150s any more)
07-10-2013 06:28 PM
Jerry Bransford That bright of a light needs a lot of amperes to allow it to be at full brightness. It takes a heavy wire gauge & a heavy-duty switch without excess wiring length for it to to work well. OR, and BEST, is to provide the current/amperes the lights require via a relay connected directly to the battery. Small gauge wiring from a small switch controls the relay, the relay provides the amperes the light requires.

I would go back to the place you bought the lights from & tell them you want a pre-wired offroad light wiring harness which will have the required relay already wired in. Then you just connect a few wires, mount the switch on your dash, and the lights will work fine and be at full brightness.

I wouldn't even consider installing driving lights without using wiring harness with a built-in relay. KC makes prewired wiring harnesses, as does PIAA, Hella, etc. & any of them will work with any other brand of light... so for example you could use a PIAA wiring harness to power your KC lights.
07-10-2013 06:27 PM
Wesboy Is it possible you got 24V lights by mistake?
I bought 24V Daylighters (ordering error) but changed the bulbs for 12V and they were good to go.
07-10-2013 05:30 PM
Water Dog What size wire and how many lights are chained together? Normally KC lights are wired through a relay, then directly to the battery with an inline fuse. If you have them wired to the fuse box, depending on the other loads and feed wire size used, you may have have a low voltage situation. You don't say how many you have, but used plural, so even two on the same wire would need a 30 amp circuit #10 wire. The relay would have to be sized for that also.
07-10-2013 04:09 PM
LBIHUI
KC Lights not bright

Running a 2000 sahara TJ. New battery and new cable connects.

180W KCs not too bright at all, initially thought it was a ground issue so I wired to the battery ground but still not very bright. Any thoughts or suggestions? Power is coming from the fuse box which is directly off battery...

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:41 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC