Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > 430N RHB Updated with Garmin City Navigator 2014.10 NT

Join Wrangler Forum Today


Thread: 430N RHB Updated with Garmin City Navigator 2014.10 NT Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-30-2014 06:05 PM
Pinchy I take that back. I think I might have 2015.10 working. I'll post up if it works correctly...
10-30-2014 03:53 PM
Pinchy I haven't had any luck with 2015.20 either.
10-28-2014 01:14 PM
nubby105
2015

Quote:
Originally Posted by jocelyn View Post
Thank you daveyjones!

Will you try with the map of 2015.10 or 2015.20?
I haven't gotten either to load. I'm running 2014.40 currently
10-28-2014 01:10 PM
nubby105
Software version

duplicate post
10-28-2014 01:09 PM
nubby105
Upgrade

Quote:
Originally Posted by johnny248 View Post
It does not look like the images uploaded correctly.
johnny248, you are running an older software version.
there is 33.x.x.x
and 50.x.x.x

If you upgrade to 50.x... you have to downgrade to 33.x... to do updates. (the software version is different from the map version)
10-27-2014 01:59 PM
jocelyn Thank you daveyjones!

Will you try with the map of 2015.10 or 2015.20?
10-27-2014 12:31 AM
Pinchy You don't need JetMouse if you have the UNLOCKED maps. It's worth finding them or unlocking them yourself if you know how.
10-26-2014 10:43 PM
daveyjones Anyways here the links to all the needed firmwares and software etc

2014.4 maps

City Navigator North America NT 2014.40

JCV

D3060130A.JCV
Get it here http://download.garmin.com/support/2.../D3060130A.JCV 796.76MB

ALL maps and IDS

ozboss | tomtom, garmin

new 50.00.07 firmware

NEW software update MyGIG 430N / RHB-RBZ 50.00.07

older 33.01.23 firmware

New Software Update MyGIG RBZ-RB2-RHB / 33.01.23 - Jeep Garage - Jeep Forum

Oldest RHB_E_23_4

http://www.mediafire.com/download/rj...RHB_E_23_4.iso

Jetmouse

JetMouse Garmin Keygen v1.5 with Checksum Fix
10-26-2014 10:29 PM
daveyjones Pinchy and Mine both worked either way


MY deck was from late 2010 early 2011 what a difference with the new updates its like having a new deck the 50.xx.xx.x firmware with the Sirius artwork is a bonus but the big blue screen is gone

Pinchy way works way faster use it
save yourself the time and energy I would believe using the Downgrade to 23.xx.x.x (33.xxx.xx is what I used with no problem however earlier in thread was stated to update maps first with 23.xxx.xx firmare) and the 2014.4 with the JCV D3060130A and straight to the 50.xx.xx firmware would save a lot of time since I did what all the other posts said to do it this way first and follow it that way

update this firmware downgrade this bla bla bla one map set at a time and one JCV at a time forget it I went from map 2011.1 to 2014.2 then over to 2014.4 with JCV D3060130A

the post is getting old I think 15 pages it should archive and a new thread started

copy out the useful info and scrap the garbage

simple new post would have links to the firmwares, latest maps and addons, Jetmouse + CS and link to the map ids for use with the Jetmouse

I think that would save a lot of problems for everyone and their frustration to find stuff instead of searching through this whole thread anymore
10-26-2014 04:50 PM
Pinchy Steps I take:

1) Downgrade to the v.23 firmware by CD because this works on EVERY year and version of RHB. The 2012s and 2015s refuse to update every time if you only download to v.33, so I figure it is just easier this way. I've also found that it is hit and miss using USB for this step. Because the firmware is so small, just burn it to a CD, and it works on every deck.

2) Upgrade using a dedicated map USB key. All that is on the key is the GARMIN folder with the map and JCV files. I'm using the 2014.40 CITY NAVIGATION NORTH AMERICA NT files. I haven't tried the 2015 maps yet. This is the lengthy portion of the update. Use a GOOD USB stick that has a fast transfer rate and it works much faster. I've been using a 64GB LEXAR USB3.0 key, it has a METAL connector and not just plastic. If it doesn't have a metal USB connector, it doesn't actually press the contacts well enough and fails to work correctly.

3) After the map update is done, I then update the firmware again to v50 by CD and everything works like a charm.


So, the moral of this story is this: Keep the map update separate from the firmware updates, and everything goes much smoother. It also goes much faster....

Total time on any deck using my CD/USB method is about an hour. I have tried doing everything using USB, but the 2012 and 2014/2015 decks are finicky for some reason. The 2011 and 2013 decks seem to be different somehow and work with USB all the way through. Maybe this is just a fluke, I don't know, but of all the decks I've done so far, this is the case. It's really stupid and annoying, but the CD method works every time and doesn't really seem to take very long anyway.
10-26-2014 07:53 AM
daveyjones after many attempts
1st I updated to 33.xx.xx.xx.xx using dvd page 3 has the download
2ng format usb fat32 using the 2014.2 gmapprom.img from TPB and JCV in root dir of the usb
Garmin/gmapprom.img and Garmin/JCV/D3060130A
the JCV should be in the same folder as the gmapprom.img
3rd tried 2014.2 with JCVd306...130a map and pnd successful
4th I had to use the jetmouse to get a serial code it worked like a charm
find the nav id number its 10 digits long in the about section in the nav settings and then using map id 3047 generate key its 25 digits long
5th using a Kingston data traveler 8 gig the usb stick has to be since win 7 first came out I used it as a boot usb for years I don't think the speed of the usb really matters
6th leave vehicle off put usb stick in front of deck and turn vehicle on
7th the 430n will boot the usb automatically reading files for about 15 mins or so then will say you want to update maps press yes another pop will come up say you have to purchase the update contact Chrysler
8th hit ok and the 25 digit bar comes enter the code you got with the jetmouse and that should start the nav update 1/1
9th map update complete pnd update complete
enjoy
I also did the 2014.4 from GPSUG and the JCV D3060130A with map id 3187 the same as above without a hitch and update to 50.0.xx.xx.x using dvd page 3 off the private server

thanks to all that put in the effort its frustrating and if it doesn't work reread the entire thread you will get it I had to read it about 6-8 times to catch it all

note make sure to use the correct version for the software install I tried to update with the Canada and Alaska maps only img and it error saying software north America + mexico is different bla bla bal

I then USed the CITY NAVIGATION NORTH AMERICA NT CNNANT2014.4.img it read no problem no conflict with update

I do believe most people are using the wrong img to try and update using only this or that check what software is installed already on the 430n and match it directly

if it says NORTH AMERICA or LOWER STATES OR CANADA AND ALASKA use the correct img

this whole process once I had the img files, firmware updates 33.xx and 50.xx, and jcv took about 2.5 hours

the whole process to get the files read to get it all done to this point was about 8 hours

and No I have not bothered to go any further with the 2015.1 or .2 files my map was 2011.1 its a totally different system no more blue screen not driving off the road into nothing

good luck
10-25-2014 09:17 PM
daveyjones
Quote:
Originally Posted by daveyjones View Post
have 2011 Laramie with 430n had software 20.xx.xx..xxx

upgraded to 33.xx.xx.xx. by burning to disc off page 3 of post

also burned 50.xx.x.xx.x ready to go

read that to not update the maps using 50.xx.x.xx.xx.

have a lockpick installed

when I try to install Canadian map update I get your version isn't compatible with Canada and Alaska maps

current version installed is OEM City Navigator North America + Mexico NT 2011.1

now using cnnat2014.2 unlock with JVC D3060130AI get the loading screen get a Proper read for the update however

I try to update with a couple different map sets and get key needed xxxxx.xxxxx.xxxxx.xxxxx.xxxxx. 25 digit key

should I use the key gen or try another img
also a how to on the jetmouse would be good also
10-25-2014 08:34 PM
daveyjones have 2011 Laramie with 430n had software 20.xx.xx..xxx

upgraded to 33.xx.xx.xx. by burning to disc off page 3 of post

also burned 50.xx.x.xx.x ready to go

read that to not update the maps using 50.xx.x.xx.xx.

have a lockpick installed

when I try to install Canadian map update I get your version isn't compatible with Canada and Alaska maps

current version installed is OEM City Navigator North America + Mexico NT 2011.1

now using cnnat2014.2 unlock with JVC D3060130AI get the loading screen get a Proper read for the update however

I try to update with a couple different map sets and get key needed xxxxx.xxxxx.xxxxx.xxxxx.xxxxx. 25 digit key

should I use the key gen or try another img
10-25-2014 03:22 AM
johnny248 It does not look like the images uploaded correctly.
10-25-2014 12:14 AM
johnny248 After spending a lonf time reading through all of these messages, I decided I would try this on my '11 Ram RHB unit.


I am pretty sure everything worked, and I was able to update to 2014.40 along with the junction views by using the instructions and the key generator. I first tried with 2014.10 and it worked, then found a copy of the 2014.40 and that seemed to work. One thing I am not sure about though is that when I view the map info, it says

Honolulu, Hawaii, Kapaa, Hawai, Kahulu, Hawaii,
[1] All

I live in Michigan, not Hawaii lpl but from where I have driven, it seems to be working fine and the hi-res junction views show up while navigating on the freeway.

Not sure if my torrent downloaded City Navigator File for some reason has the Hawaii titled stuff as an error, or if my maps are incorrect.

Has anyone else had this problem? If it actually is a problem.

On this last update, it also changed the Nav software version changed to 3.0 I cab remember exacty, but I believe it used to be 2.5

The look of the nav functions changed also. They are now dark based like the 50.xx.xx radio update. Before they were blue, and the where to screen had a magnifine glass before and all of the icons have changed.

I was going to try to update to the 2015.xx maps but wasn't sure if anyone was successful in doing so.

I have attached a couple of images. Is this what others units are doing also? Like I said, everything seems to be working fine but since this kind of a work around hack, I just want to make sure that it seems right.

Thanks
10-20-2014 01:29 PM
Broker23
Quote:
Originally Posted by relyt View Post
I'm not positive, but I think it all depends on which jcv files you install. You may be able to update just the jcv files and not reload the entire map.
Does any one know if this can be done?
10-20-2014 07:37 AM
relyt
Quote:
Originally Posted by Broker23 View Post
Hmm I wonder if i can change a setting and make it bigger?
I'm not positive, but I think it all depends on which jcv files you install. You may be able to update just the jcv files and not reload the entire map.
10-20-2014 05:50 AM
Broker23
Quote:
Originally Posted by relyt View Post
Large junction is the full screen I believe. I'm not positive, but I think that's how I remember it from my trip to ND.
Hmm I wonder if i can change a setting and make it bigger?
10-20-2014 12:23 AM
relyt
Quote:
Originally Posted by Broker23 View Post
Looks Like I have it already
Large junction is the full screen I believe. I'm not positive, but I think that's how I remember it from my trip to ND.
10-19-2014 10:07 PM
Broker23 Looks Like I have it already

10-19-2014 07:15 PM
Broker23 Does the 2014 Already have large junction files? I have never used the navi in my Jeep
10-19-2014 03:17 PM
krc1075 Can someone PM me. I'm trying to figure this out, can't seem to figure out how to get those files from the sites......
10-17-2014 07:54 AM
THUDDOME
Quote:
Originally Posted by Pinchy View Post
You obviously live in an area with no major expansion or roadwork. There are complete sections of my city missing in the older maps, roads that no longer exist, roads that are completely missing... Not to mention the fact that until 2014.40 my own house didn't appear in the maps - and my street was built in 2007.
You live in Canada.....you have streets there? or GPS?

That doesn't count
10-16-2014 01:47 AM
Pinchy
Quote:
Originally Posted by THUDDOME View Post
From a lot of experience, map updates usually are not actual updates to the maps, they are updates to business information such as addresses and phone numbers and such. That stuff changes so much it's hard to keep up. My point is unless your maps are years old it might not be worth the risk or your time to update them. It's easy to get update happy and it would be a "bad day" if you brick an $1800 head unit. If it ain't broke, don't fix it...
You obviously live in an area with no major expansion or roadwork. There are complete sections of my city missing in the older maps, roads that no longer exist, roads that are completely missing... Not to mention the fact that until 2014.40 my own house didn't appear in the maps - and my street was built in 2007.
10-09-2014 11:11 AM
THUDDOME
Quote:
Originally Posted by MJK View Post
I'm back with a working system. It turns out I forgot I had a lockpick hooked up to the stereo. I removed the lockpick and its now running the latest firmware and working fine. Now I'll have to wait for the 2015 maps to get released.
One of the firmware changes I noticed is when playing music from the harddrive, when you list artists, pick an artist (shows songs) then hit the list button again and it lists the albums... been waiting for this, before it just listed all the songs in alphabetical order...

To Everyone:
From a lot of experience, map updates usually are not actual updates to the maps, they are updates to business information such as addresses and phone numbers and such. That stuff changes so much it's hard to keep up. My point is unless your maps are years old it might not be worth the risk or your time to update them. It's easy to get update happy and it would be a "bad day" if you brick an $1800 head unit. If it ain't broke, don't fix it...
10-09-2014 11:06 AM
THUDDOME
Quote:
Originally Posted by Spicoli View Post
Nevermind, I've found the 50 firmware update link after reading through the thread.

Grabbing a copy of 2014.40 as it seems that is the last working version able to be updated, even though 2015.20 is out.

Going to install the maps first, then work on the Firmware.

Grabbed the D3060130A.JCV file as well as the City Navigator North America NT 2014.40 (Image Unlocked) file.

Will report back with results.

How are you guys updating the firmware? CD or USB? Just throw the .iso file on a blank FAT32 formatted flash drive or burn to a blank CDR? From what I've read, it's recommended to burn the firmware onto a CD vs USB?
Use a thumb drive, CD or DVD takes forever. If possible use a good thumb drive like Sandisk or PNY
10-09-2014 11:05 AM
THUDDOME
Quote:
Originally Posted by biddysere View Post
Well, being ignorant, I was thinking a gps is a gps. Now I am understanding that my radio, the RER, is not able to update maps. Has to be some way to do it though?!
This thread is for the RHB, RER is completely different, different manufacturer. Not sure but I would guess there's a thread out there for the RER.
10-09-2014 10:54 AM
THUDDOME
Quote:
Originally Posted by THUDDOME View Post
Let me share some links that make life easier:

For a list of Map IDs (FIDs)
ozboss | tomtom, garmin

For map downloads (NOT Torrents)
Garmin Maps
Just reminding folks, stay away from torrents
10-07-2014 11:57 PM
MJK I'm back with a working system. It turns out I forgot I had a lockpick hooked up to the stereo. I removed the lockpick and its now running the latest firmware and working fine. Now I'll have to wait for the 2015 maps to get released.
10-01-2014 10:20 PM
MJK I think my stereo is now dead. I figured I would update just the firmware of the unit and wait till the 2015 maps come out sometime in mid October according to the navigation map site. I went therought the update process and then the screen just went black. I let it sit maybe 30 minutes and it was still black. I then tried turning it on, pushing buttons and finally turned off the key. The unit is now just black.

Any ideas beforeI go to the dealer and play dumb?
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:18 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC