Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Engine Noise

Join Wrangler Forum Today


Thread: Engine Noise Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-24-2012 06:48 PM
pkmcd99
Quote:
Originally Posted by muleman
2008 wrangler x no mods. 5000 miles. When i start the engine cold it sounds like rods knocking. Anyone else have this problem. Changed oil at jeep dealer at 2600 miles. This started shortly after. Thanks K.C.
Its common cold start up noises. Lucas oil sunstitute 1 qt and use an oil filter with anti drain back valve like fram tough gaurd or equivilant. Pullies also ocasionally make start up noises but youll have to live with them. Get a block heater also and plug her in during the winter.
08-26-2009 01:29 PM
TXRLK Switch the filter to a Motorcraft FL-400S.
It's a larger capacity filter and has an anti-bleedback valve.
If you're slow, like me, it will take about three minutes to swap the filter.
08-18-2009 09:08 PM
muleman Done some checking. They put a perform-X filter on it. This does not have the anti bleed back. Filter was the problem.
08-14-2009 09:31 AM
UnionOffRoad
Quote:
Originally Posted by Hitchhiker View Post
I'd take it back and have them check it or change it again. Maybe the grease jockey put the wrong oil in it.
Grease Jockey. LOL thats mint
Possible bad oil filter. Seeing alot of those at my dealer, we're Cadillac, Chevy and Buick but... Possible
08-12-2009 04:31 PM
Codeman911 I would use Royal Purple fluids. Best stuff I've seen.
08-11-2009 08:57 PM
Hitchhiker I'd take it back and have them check it or change it again. Maybe the grease jockey put the wrong oil in it.
08-10-2009 07:03 PM
muleman
Engine Noise

2008 wrangler x no mods. 5000 miles. When i start the engine cold it sounds like rods knocking. Anyone else have this problem. Changed oil at jeep dealer at 2600 miles. This started shortly after. Thanks K.C.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:13 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC