Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Stuttering at idle, has tried everything.... please help

Join Wrangler Forum Today


Thread: Stuttering at idle, has tried everything.... please help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-22-2009 01:55 AM
rrich What I would do is first read the thread I just posted - called "Propane trick."
Then make the device. $5?

Take it with you - tape the hose in the air cleaner snout so propane can be added.

Make it stumble like your complaint. Add a bit of propane - see if it straightens out or has no effect.

If it's too lean like you suspect, it'll run much better while you add "just a touch" of propane (the propane will be just like adding a little gasoline.)

If it has no effect, then you know it's not too lean.

How's oil pressure when you stop and it runs like that? TJ gauges are not actual oil pressure measurements - they aere interpreted values by the PCM - and slow to react. Wondering if it's starving for oil on a stop - oil too thin could be a reason for oil starvation (lifters get starved, thus not operating the valves properly?)

Get it warmed up, look at the oil dipstick - runs off? Too thin. Smell it for signs of gasoline pollution (makes it thin too.)

Have you measured fuel pressure? Harbor Freight has a fuel pressure gauge for about $20.
09-22-2009 01:17 AM
sarap I appreciate these answers but I have checked on those with no response, I think it has to do with my fuel system, bc when it starts to sputter it feels like my jeep is not getting enough gas but sometimes when Im driving, unusally downhill my jeep acts like its getting too much gas but its not changing the rpms. And my jeep acts up more often during the 3/4 to full and the 1/4 to empty. I recently started using gas without ethanol and that seems to help a little. Thank you for any info you can share.
09-15-2009 03:39 PM
Rubi Unlimited I cleaned my engine and later found the vacuum hose for the dash air vent controls was off its connector on the side of the engine. And as of this morning I am having problems with the jeep seemingly trying to find or change its idle speed which seems to make the vesicle surge ahead or knock for a second like it wants to die. Can a cleaning of the engine damage or cause problems with the Idle air controller?
09-09-2009 02:58 PM
Jerry Bransford Since you have already cleaned the IAC which provides all of the engine's air at idle, which is the usual suspect with this problem, your next step is to replace the TPS (throttle position sensor). The TPS can cause this exact same symptom, it did on my TJ too and replacing it cured the issue... at least until my IAC finally got dirty several years later to produce pretty much the same symptom again.

The TPS is inexpensive to buy, $40 or so, and with only two torx-head screws holding it to the throttle body, it can be replaced in just a few minutes too. No need for any calibration, the PCM (engine computer) will quickly recalibrate itself to the new TPS after a short while.

By the way, the TPS gets dirty inside (it cannot be cleaned so it must be replaced) so it sends eratic data to the PCM which can cause all kinds of idle and acceleration issues. Good luck with it.
09-09-2009 02:32 PM
woods453 Does it ever give you trouble when you try to crank it?

This weekend my Jeep wouldn't crank and I noticed that battery corrosion had eaten away the shielding around the nearby wiring harnesses. The harness is $1200 so I got some butt connectors and a new piece of wire and repaired the damaged wires. Now it runs like a champ.
08-31-2009 03:22 PM
Tuff_Mudd maybe the ignition coil? i had the same symptoms on a different vehicle.
08-31-2009 11:22 AM
woods453 It happens to me too. Mine's usually because of battery terminal corrosion.
08-31-2009 01:00 AM
meyers First thing I would check is all the ground wires make sure they are all clean and tight. Sounds like the kind of intermittent problem a loose a bad ground could cause. Seems like you have changed every thing else.
08-31-2009 12:57 AM
Rawkon Sea foam it. autozone its the only thing in a can that actually works.

Mopar motors are notorius for carbon buildup which can make your motor do funny things. check your spark plugs, and if that fails it may just be your PCM. which is very easy to swap out.
08-31-2009 12:15 AM
sarap
Stuttering at idle, has tried everything.... please help

Hello, I have a 2000 jeep wrangler, 126000 miles. 2.5 liter 4cyl. I have been dealing with this problem for almost a year now with no solution. This is a very intermittent problem. What happens is when I come to a stop and idle my jeep with start to stutter and act like it is going to die, but it never actually does die. It can go days without doing this or it could do it non stop for days. The only way I am able to control it, is to rev the engine and start going, which causes the jeep to hesitate a little then start going, or i have to turn it off and then back on again. I have taken this to multiple jeep mechanics who have been in the buisness for years and they can't seem to come up with a permanent solution. Heres the work that has been done... cat converter replaced, o2 sensors, tps sensor, map sensor, spark plugs and wiring, values in the head gasket tested, idle air control sensor, (solenoid around that has been throughly cleaned out) the exhaust was checked for leaks and a new donut was placed on it, vacuums were all inspected as were all the belts, computer was reset and battery was tested. I put good gas in my jeep and I always use the same type. OH I forgot the best part, this entire time I have not had my check engine light on, if the jeep is scanned when it is running fine no codes come up, but if the jeep is stuttering the only thing that comes up is a slow to respond rear 02 sensor, this sensor has been replaced and checked. The most recent work I had done was the cleaning around the idle air control solenoid which made my jeep run perfectly from tuesday to sunday, i got gas on sunday and within45 min it started to act up again. The only thing I can think to try is replacing the gas cap, but I think if it was loose or worn I would get atleast a check engine light thrown at me. Sorry this is soo long but I really appreciate any help you can give me. thank you! oh ps, i did notice that my gas cap does not make a pressure release noise when I take it off like most other cars.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:50 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC