Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > HVAC heater control panel issue / melted wires

Join Wrangler Forum Today


Thread: HVAC heater control panel issue / melted wires Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-01-2009 10:06 PM
distortedtj Common issue. Read over this thread........

http://www.wranglerforum.com/f5/heat...rol-16174.html


If you have anymore questions feel ask.
09-01-2009 09:47 PM
alfman45
HVAC heater control panel issue / melted wires

Hey guys,

Did some research on the site before asking, but not sure any apply to my issue. I have a 99 with AC with an erratic ac control panel. Sometimes it works (all speeds), sometimes it doesnt. AC used to kick on and off in 4 second intervals but lately would not kick on at all..so i replaced the heater control switch with a used unit that worked in another 99 and it worked on speed three only and the ac wouldnt kick on.

Looked behind the unit and this is what i found:




Its burned on the second wire terminal....Whats the deal?...i saw some suggest a blower resistor, but only when speed 4 worked...was there an overload of some kind? why wont the ac kick on? what do i need to research next?

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:56 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC