Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion > Left Turn Signal Grounding??

Join Wrangler Forum Today


Thread: Left Turn Signal Grounding?? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-15-2009 10:28 AM
ChiefMateSam
Left Turn Signal Grounding??

For the last 3 years, I've had a grounding problem on my 1999 TJ Sport. For the first 20 minutes, no problem. After some jostling around, when the brake pedal is pressed, the left turn signal lights up on the dash and front fender (turn signal stalk is in neutral position). I had a trailer harness installed 9 years ago, but I removed it and it still didn't help. I also replaced the turn signal generator, but that didn't help either. I've traced some of the wiring out and wiggled it trying to reproduce it, but nothing. I've taken all the bulbs out and inspected them and put electrical grease in the sockets, but still nothing.

I've gone a little nuts trying to chase this ground! Can anyone help or have any ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC