Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Same Old Heating Issue

Join Wrangler Forum Today


Thread: Same Old Heating Issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-14-2009 09:21 PM
Mocaco_Luc im having the same issue with no hot air coming out. the heat is very minor to almost nothing. mine is a 1999.
10-14-2009 04:18 PM
ghettocowboy if the thermostat has been removed will it blow lukewarm air?
10-14-2009 03:03 PM
gaddman You can try and backflush the heater core. Simple process that I've done on my wife's VW and worked like a charm with no harm to the core at all.
10-14-2009 03:03 PM
snwchris First check the vacuum line under the hood that connects to the barb on the engine, (rear drivers side).

If that's not it, check the vaccum lines to the control panel, by simple removing the couple of scerws for the center dash bezel.

Next would check fuses.

After having vehicle run til warm, check hoses going into firewall. if one is significantly colder, unhook and flush hose.

Chris
10-14-2009 12:40 PM
thanley
Same Old Heating Issue

I tried and couldn't find some previous threads on this.

I bought my Jeep back in June from a buddy. I knew the heat wasn't working that well. The fan blows great, but it's just not getting "hot air" into the cabin.

I really don't want to do the dashboard teardown to get to the core unless needed. Aren't there some other tricks to clear a plugged core?

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC