Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Low fuel pressure with new fuel pump & filter

Join Wrangler Forum Today


Thread: Low fuel pressure with new fuel pump & filter Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-08-2009 06:33 PM
crbnfbr
Low fuel pressure with new fuel pump & filter

I recently changed out the fuel pump along with the tank on my mom's 90 2.5L. It ran fine for a day or so, but still had it's intermittent starting issues. So, I took the ICM to autozone, and they said it was fine. However, after reinstalling the ICM the engine ran terrible. It idles rough and has no power, especially under WOT.

So, today I tested the fuel pressure, and it only read 10psi. According to the Haynes manual it's supposed to be 14-16psi. I pinched off the fuel return line, and it remained at 10psi. Which supposedly means the regulator is fine, and that either the fuel filter or pump is bad but both are brand new.

I'm wondering if the gauge could be wrong since it was a 100psi and the manual said to use a 30psi.

I'm really getting frustrated with this thing. Any ideas you have would greatly be appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:55 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC