Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Ignition Timing Help Needed...Distributor install

Join Wrangler Forum Today


Thread: Ignition Timing Help Needed...Distributor install Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-10-2009 06:06 PM
jvc rotor is pointed at 3 o’clock position (something like that ??)
11-10-2009 01:31 PM
alj9115 Thanks, but more of a description pertaining to which way the distributor cap points in relation to having the engine #1 cylindar at TDC. In other words, should the cap be pointing towards the #1 cylindar, at 3 oclock etc.

Thank you Banipal.
11-09-2009 09:00 PM
Indy Something like this??

Attachment 12882
11-09-2009 04:55 PM
alj9115
Ignition Timing Help Needed...Distributor install

99 Wrangler 2.5 w/ 97xxx miles

I was doing a tune up and removed the distributor without marking it. While it was removed, my wife thought since the hood was down it was ready to go. She tried to start it, and in turn, rotated the engine. I have a Chilton manual and have tried to find the set up for a 99, but it's not listed. What is the correct oil pump orientation? Some years list 3 oclock, other list 6 oclock... I'm stumped. I've got it set to TDC according to Chilton, but don't know which way the rotor cap should face either. I've tried several ways, but nothing seems to fix the issue. She wont run!

I'm getting spark, getting fuel, getting air...just not timed right.

HELP Please!

drew

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:15 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC