Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > After 2.5 lift ABS/ESP/BAS light stays on

Join Wrangler Forum Today


Thread: After 2.5 lift ABS/ESP/BAS light stays on Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-06-2013 12:19 PM
OBWan I am this same situation right now. I just pulled out a 4" coil lift and installed a rock krawler 3.5" mid arm lift. We center the steering wheel. The jeep tracks straight and it accelerated and brakes straight but the ESP/BAS light is on and it won't clear itself. I did the 3 key turn thing to get any error code but it just comes back d0ne. Not sure what to do next.

By the way holy cow is this lift sweet. The jeep rides so much smoother now and feels rock solid

Mike
07-18-2013 11:49 AM
5150Rubicon I don't mean to hijack...but feel this is an important topic especially for those of us that are about to do a lift.

What is the lesson learned here?

Should we do the procal and center the steering wheel immediately after the lift install, before driving off for the first time? Would that solve these things?

Thanks!
07-18-2013 11:26 AM
Inspector857
After 2.5 lift ABS/ESP/BAS light stays on

I just finished installing a 2.5" lift kit from Rock Krawler suspension and a set of Pro Comp Extreme MT2 LT305/65R17's on my wife's 2010 Wrangler Unlimited Sport and ran into the same issue as well as having the ESP system firing off when I went around left turns on the way to the alignment shop to correct my steering wheel as it was cocked to the right after the install. Then the ESP/BAS light came on effectively disabling the system. After getting the Alignment done the code would not clear even after the mechanic tried to reset / Recalibrate it using his code scanner. So I headed off to the local Jeep Dealership to get it reset. Fortunately they could not do it until the next day so I set an appointment and resolved to paying for 1 hrs mechanics time. The mechanic explained that the new jeeps have a pitch/yaw/speed sensors that takes steering wheel angle (sensor), tire speed(sensor), vehicle pitch/yaw(sensor) into consideration, performs a complex set of equations and then fires the ABS system in an attempt to compensate for and correct the apparent off center of gravity situation that it has interpreted. OK way to much electronics... Anyways on the way out of the Jeep dealer's driveway the sensor Reset / Relearned itself thus saving me that extra $70+ Dollars I would have spent there. No more problems since.
05-16-2011 04:36 PM
jrohan07 I checked the wires to the wheels too but the sensor was broke inside of the hub.

Perform simple alignment on JK-Forum
05-16-2011 03:16 PM
DROD33 I just installed the AEV 2" lift and I also have the ESP bas light on, I have checked all the wires going to the wheels, BUT my alignment is out, any one know If that was cause the lights to turn on
05-16-2011 03:13 PM
rics1997 One of the main reasons I lifted mine by going to factory stiffer coils. Even though they really can't do what they did. Who has the resources to fight them over it. They know you won't hire a lawyer and wait out repairs for $218
05-16-2011 02:28 PM
jrohan07 UPDATE.
After taking to the dealer today they said the left rear speed sensor was broke at the hub and because I had a lift and wheel spacers that it would not be covered under warranty.
I tried to state the lift and wheel spacers had nothing to do with it as the cause but the dealer said doesn't matter.
He asked who did the work and I confessed to it and that I probably broke it.
218 dollars to fix a 15.99 part I could have ordered and put on myself.
He also stated if you would have just removed the lift and wheel spacers, and then brought it in it would be covered under warranty.
Lesson learned for 218 but I sure as hell did not want to remove the lift or wheelspacers again.
I will however remove and put back to OEM if something else happens and I want it covered under warranty.
He stated that Chysler is telling them that any modifications to the Jeep, they can deny warranty which includes lifts, wheel spacers, CAI, and even exhaust.
They did do the automatic transmission lines recall under warranty and flash the ECU.
05-16-2011 08:25 AM
jrohan07 I do remember having to sit on the rear hub just to get the axel to drop low enough to put the coil spring back in and I think I heard a small snap.
I bet the sensor wire broke and the ECU knows that there is a open therefore the lights stay on.
Word to the wise. Use coil compressor if you do it yourself and be careful of the wires stretching to far.
Thanks!!
05-16-2011 08:11 AM
jannikt Most likely you damaged / cut a cable that goes to the wheel sensors when you installed the lift. The lift and spacers should not cause the ABS/ESP light to turn on just by itself. But the cables that go to the wheel sensors are pretty delicate and not very well protected. It's very easy to damage them while working around the suspension.

Of course there is always the possibility that the system failed just by coincidence at the same time as you did the lift.

In any case, get it fixed. The ESP makes a huge difference in a high-center-of-gravity vehicle like the Jeep.
05-15-2011 09:16 PM
jrohan07
After 2.5 lift ABS/ESP/BAS light stays on

I searched the forum and tried all solutions except take it to the dealer but maybe somebody can help.

A few days ago I installed a RC 2.5 BB w/shocks and followed the instructions exactly.

I only did the front at first and before I drove it I recenterd the steering will with the draglink turnbuckle perfect center.

I drove it for a few days with no issues or ABS/ESP/BAS lights staying on and today I deceided to install the rear.

Checked the steering wheel for center before I drove it again.

Went for a test drive and about 3 minutes the ABS/ESP/BAS lights came on and will not turn off.

It tracks straight as an arrow and the steering wheel is centered.

I also have 2.5 wheel spacers on all four hubs.

I do not want to disable the TCS with the wheel dance so before I take it to the dealer anything to look for?

When I go to the dealer should I disclose I have a small lift with wheel spacers? The lift is not very noticable but the wheel spacers are.

I don't want to be denied warranty if something is actually wrong with ABS or sensors.

I do not want to remove the lift or wheel spacers.

Can you turn off the lights by pulling the J6/J7 fuse?


I have a full warranty

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:52 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC