Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > Signal and brake lights just quit working

Join Wrangler Forum Today


Thread: Signal and brake lights just quit working Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-14-2010 11:58 PM
fullboar01 thanks i will try its all just a bit weird
03-14-2010 11:03 PM
89YJislander When i had some eletric problems i just replaced the ground wire, just a sugestain
03-14-2010 10:39 PM
brent in az After reading this twice I have to say as weird as it sounds that seat swap-out and absences of signals/taillights immediately after is prolly not a coincidence.

I've swapped seats out before. I've never noticed any auxiallry grounding wires or any electrical wires whatsoever in that part of the undercarriage. You were under the jeep, right?
03-14-2010 10:06 PM
Jaydogg25 what i like to do to make sure is use a test light and test every fuse, in every location. i have seen fuses look good but are not. make sure to have ign on to test fuses easier.

from that point if they all look good i would go to switch and test wires there. (break switch & parking light switch), now if it's turn signals then check relays for that.

cant say i have seen that issue from replacing a seat..though i have had to change my break switch several times on my 95.
03-14-2010 09:37 PM
derekshep only thing i can think of is maybe you hit the wires going to them somehow? othere than thats i'm lost
03-14-2010 09:27 PM
NAVYCHIEF both of them? one of them?
03-14-2010 08:35 PM
fullboar01
Signal and brake lights just quit working

Hi Just replaced the front seats in my yj, and for some reason the signal and brake light just quit working!!!! WTH? checked all the obvious fuses, bulbs etc still nothing. just maybe someone has a idea!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:34 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC