Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > TJ - Loss Of Compression???

Join Wrangler Forum Today


Thread: TJ - Loss Of Compression??? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-20-2010 03:32 PM
terrible2 You know when I know im up for a big fight, I get pretty nervous. A little because I know that I always know it will be a uphill battle, but also because I know that during the course of the argument i will get pissed and there will be yelling, and it doesnt help that theyre on the phone and you cant exactly choke someone over the phone.
03-20-2010 03:14 PM
Jerry Bransford No news on the stolen Jeep, I'm kind of dragging my feet on the insurance thing in ever decreasing hopes the police will find it. From the posturing AAA has already begun, I'm going to get screwed big time. My spreadsheet has an even 100 documented items on it now with the real/non-exaggerated total just over $23K, not including the cost of my TJ itself.
03-20-2010 02:57 PM
rrich Jerry - it's like a doctor telling you need a heart transplant because you have high blood pressure.

Hmmm, Uh Oh, - I'm on the transplant list! -- Really I am.

Any information on your stolen Jeep? How bad is the insurance company playing games with you?
03-20-2010 02:51 PM
rrich I didn't know SE meant 4 cyl.

This is where it gets tricky - if the plug wasn't firing the compression can read low - or - if the compression is low, it could foul a plug.

It's the chicken or the egg thing. LOL


Remember it's only been the dealer that said low compression -- with no numbers to prove it. Owner said rough idle.

Now that a "good" plug is in it and no CEL, compression readings may have improved over the non existent dealers readings - if he did them at all.

Current info is always the best along with history.

It could even be something easy like a vacuum leak -- that caused the misfire -- that caused the O2 Sensor to say "lean" -- causing too much O2 in the exhaust -- causing the ECM to think it's lean -- causing an over rich condition -- that caused the fouling -- that caused the cylinder to get wet -- that caused low compression reading.

One little thing can lead to another "causing" confusion! "Cause" it's complicated!

Sorry, I had to -- "Cause" I could.
03-20-2010 02:46 PM
Jerry Bransford Any Jeep dealership that says an engine must be replaced to fix a stuck valve should have their licenses revoked. That's like saying the axle must be replaced when you have a flat tire. IF you have a stuck valve, the worst you could possibly need is a valve job. Rrich gives more details but suffice to say your dealer was lying to you.
03-20-2010 01:38 PM
exboomer I agree with the above, more information and further diagnosis are needed. He did mention it was a 1997 SE which is a 4 cylinder. In defense of my previous reply, I assumed when he replaced the spark plugs, if the #3 plug was fouled or looked different than the rest, he would have mentioned that. I do understand if the cylinder wall was washed out, or there was build up or crap in the cylinder, or the compression test wasn't properly performed it could change the compression readings. I assumed the diagnosis was beyond that point.
03-20-2010 11:43 AM
doclouie rrich knows what he is talking about. More info and we can help.
03-20-2010 11:14 AM
rrich Don't panic just yet - most of these cases are actually something simple and cheap.
But - we need more info!

By your saying only 75% of the power we have to assume it's a 4 cylinder?
And you are assuming that the low cylinder is completely dead. That's almost never true. When compression is low it lowers the power in that cylinder, but only by a portion. The power loss is usually most noticeable at idle. But that's why it's still drivable.

Low compression can be caused by several things, most of which are repairable without an engine replacement. Many are minor things.

Answer all these please --- We need to know:
4 cylinder?
What Year?
Miles on the engine?
Any recent work done on the engine other than what you mentioned?

The misfire/rough idle - did it happen suddenly or over a long period of time?
Any noises or clattering?
Starts hard or easy? Anything unusual when starting? For how long?

Try this - hold a clean rag over the throttle body (air cleaner off) - slowly put it over it till you get a reaction - does it idle smoother or just die? Try it several times to verify.

When you replaced the plugs, was any looking different from the rest? Oily, black, bent up, electrode smashed, etc.? Hopefully you still have them and show us a picture. (Some scanners will do a good job, better than a camera.)

What brand were they, and what did you put in?

Did the dealer actually do a compression test or just assume it's compression. By saying the only repair is a new engine he's demonstrated his incompetence. Nothing he said is believable now.

If you can do it yourself, do your own compression test and tell us the readings. Or take it to a shop and have it done. Find a shop that others recommend, tell them you want both dry and wet tests - GET THE NUMBERS AND POST THEM HERE. If they don't understand or object to a dry/wet test - run away!
And ask what that plug looked like - dirty?
Find out what they think, but do not do it until you check back here.

Total incompetence is on a rampage, and with the economy down people are desperate to sell things you don't need. Dealers are not the only ones that have to hire what they can get. The hardest part of owning a business is getting employees that know what they are doing and are honest and reliable.
When I had my shops I had the same problem, and I paid higher that any other shop locally to attract the best. I usually had to hire and let go as many as 20-25 "mechanics" to find one that I'd keep. Even then --!


It could be something very simple, like a plug was fouled, making that cylinder dirty inside. Then you put in another new plug but that new clean one got instantly fouled from all the crud left over in the cylinder. I suspect that may be the case since your CEL hasn't come back on - yet.
But we need to know the above to be of help.

Let us know and we'll go from there.
03-20-2010 10:58 AM
exboomer Someone needs to do a leakdown test and that will tell you where your losing cylinder pressure in cyl #3. If the pressure loss is past the rings then maybe another engine or a rebuild is the answer. If the leakdown test shows a valve problem, you will need the cylinder head removed and inspected. Pull the trouble codes and verify what thay are. Probably a P0303 cyl #3 misfire. If a cylinder has low compression, putting secondary ignition parts on or any other external part will not fix the problem. Maybe you have a valve hanging up in a valve guide? Good luck. Whatever you do, do not let someone talk you into running an "engine crankcase cleaner" i.e. BG in the engine.
03-20-2010 07:43 AM
Atthehop I assume they took a compression test of each cylinder. If indeed they did and they confirmed low compression how low was it compared to the other cylinders. If it was slightly lower then it may be leaking past the valves and a valve job would be all it needs if it is leaking past the piston rings then you need a overhaul. Since dealers only know how to replace parts they will recommend replacing the engine. It covers their ass since their mechanics are not trained to repair only replace.

I worked in a dealer from 1968-1981 and we overhauled every component in a vehicle unless it was damaged beyond repair and the cost was more than a new component.
03-20-2010 04:20 AM
terrible2 Yes very possible he was wrong. Im not too much of a gearhead but the dealership is the worst place you can go for advice. I trust hole in the wall's over dealerships. Youve got to realize that though theyre certified and they deal with your car all the time, they dont know squat unless youre lucky. Most of them just replace crap and blame it on something else. This idiot at CUTTER DEALERSHIP HAWAII tried to tell me he couldnt hear what was wrong with my Jeep due to the aftermarket suspension, I was like wtf, all I put in my suspension was a lift kit I dont even know how a new suspension could change anything minus the noise from the tires.

DO NOT GO TO CUTTER DEALERSHIP HAWAII
03-20-2010 04:13 AM
fretout
TJ - Loss Of Compression???

First off, I want to apologize. I'm sure there is some forum law that states that you can't start a new thread with a thread count of 2, but I digress...

I have a 1997 Jeep Wrangler TJ SE that has a loss of compression in cylinder 3. Originally, my check engine light came on, so I dropped it off at the local Chrysler/Jeep Dealership/Mechanic. They said that they are not sure why there is a loss of compression, but said that it is most likely a valve is frozen up, and this is causing the lack of compression. I asked them if there is anything that could fix the problem and they said that a new engine was the only fix.

I was in denial, so I replaced the rotor, cap ignition wires, spark plugs, battery, fuses, electrical harness, in short everything electrical. I also perfomed a full tune up in an effort to alleviate the problem.

The strange thing is this. I drove the Jeep home and somehow I was able to maintain highway speeds, and there seemed to be little-to-no vibration at all. The Jeep will Idle rough, but it never dies. Also, the Jeep has run for around 200 miles and the check engine light hasn't flashed on, but the TJ still idles rough.

I wanted to check with resident experts here and ask for some advice. How would you recommend fixing this problem? Could it be possible that the Mechanic was wrong? I just don't understand that with 75% power (because one of the cylinders has little compression) that I can maintain speeds, or drive at all.

Thanks for all responses.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:15 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC