Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 89 YJ clutch issues

Join Wrangler Forum Today


Thread: 89 YJ clutch issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-10-2012 04:24 PM
Ernie I I too am haveing poblems with mine. I just installed all new parts from a kit I picked up at Auto Zone. This is the third time I have pulled the trans for the o'ring keeps poping out. This makes me think the cylinder is junk. I will be making a trip to AutoZone for a refund.
04-29-2010 10:43 AM
Nucklez Hey guys, this is my first post here and I would like to comment on this product as well. I just swapped my engine with a rebuilt. While I had the engine out, I purchased the clutch kit from Autozone with the slave cylinder and all. When I got home, I realize that the kit was missing the pilot bearing. I drove all the way back out there and they gave me one. Now I have it installed, and now I'm having a problem with it knocking really loud when the clutch is all the way out. If I set my foot on the peddle, the knocking stops. I checked the fingers on the PP after we got the tranny and engine lined up, and none of the fingers were bent. Either I got a bad TO bearing, or maybe bleeding this thing some more will fix this. I haven't been real happy with this kit though.
04-19-2010 02:46 PM
SUBZEROCOOL If the first few failed thats a sign of a defective product. Id keep all reciepts, document time spent removing the broken clutch and speak to the manager bout a full refund. I replace all my clutches w/ Exedy, Autozone clutches are over priced and garbage. Ebay linky

EXEDY CLUTCH KIT SLAVE 89-92 JEEP WRANGLER YJ 4.0L 4.2L : eBay Motors (item 390020724373 end time Apr-24-10 19:19:00 PDT)
04-19-2010 01:34 PM
nawtaz i have had the same problem with autozone bought complete clutch rebuild kit from them the first one lasted 3 days the second lasted about a weeks worth of driving am going back to the store today to see who they are going to pay to do the job AGAIN as I am tired of putting defective parts in my jeep.
03-28-2010 03:28 PM
chaduscg The last time I pulled the transmission down, the throwout bearing had been released from it's straps like it supose to do. This is why I am confused and thinking of pulling the trans one more time to put the original clutch and throw out bearing back in. The clutch and throwout bearing only have 8,000 miles on them and are in good shape. What do you think? Becuase if that works, that would tell me that Autozone has a fualty product in my eyes.
03-28-2010 02:17 PM
Garyk If it keeps blowing O rings out of pressure side, I would wonder if the throwout bearing is moving.
03-28-2010 11:30 AM
chaduscg
89 YJ clutch issues

I have a 89 Yj with a 4.2 and AISIN 5 speed. Three weeks ago my transmission locked up due to 5th gear coming apart, so I pulled the the transmission ( had rebuilt) and all (including master cylinder) the clutch componets and replaced them with parts from Autozone. The clutch kit is a NU-1916 Duralast clutch kit that I have had to return twice now, due to the first kit had a bad throw out bearing and the second kit built up to much pressure and blew the o-rings out of the pressure side of the slave cylinder. Well, I just got finished putting the third clutch kit in and it has done the same thing and blew out the new o-rings on the pressure side of the slave cylinder. Has anyone bought one of the kits before and had any luck with it or has anyone had this same problem with just any name clutch kits? Is it possible for the master cylinder to be building up to much pressure that the o-rings blow? I am stuck and don't know where to go with this. I have pulled my transmission 5 times in the past week and two days..

I really could use some input from people that have been down this road before

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:17 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC