Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > water leak from behind engine block

Join Wrangler Forum Today


Thread: water leak from behind engine block Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-20-2010 09:33 AM
Wench yea im an idiot...I just realized I had my heat+defroster running this morning and that was causing the leakage....I didnt really drive it far but I guess i did enough for it to look like niagra falls coming from up under my jeep-jeep...hooray for a good compressor!
05-20-2010 09:23 AM
yburn passenger side is where your AC evap drain is make sure that is not what is leaking B/C it is supposed to !!
05-20-2010 08:16 AM
Wench I too have an 03 Wrangler X 4.0L that leaks passenger side between the FW and engine. Did you get his issue fixed with yours? If so please let me know what you did. I'm thinking a leaky hose...I hope these models dont have bad freeze plugs..
04-21-2010 04:00 PM
Jerry Bransford I got your PM but after reading through the thread and putting my thinking cap on, I'm not going to be any help on this. It's just too hard to do leak diagnoses over the internet or give any real help beyond the solid help you've already been given above. Best of luck with it.
04-19-2010 05:56 AM
popa Couldn't it be the water from the AC evaporator (when the ventilation is directed towards the windshield, it automatically runs the AC in order to dry the air)?
04-14-2010 11:45 PM
JeepersdoitDeeper Could be the core or a hose. I just had a leak on my XJ this month. No visible leak at the hose, but I had water running of the hose necks none the less. Changed the hoses first since that was the easy fix, and sure enough, problem solved.

If the core is bad, and money and the repair is an issue, you can get a small length of 5/8th's copper pipe, about 4-5" and just attach the hoses together and bypass the core all together. You wont really need heat now that summer is here. Will give you a chance to save or get it repaired and still be able to drive it.
04-14-2010 11:39 PM
jconway I tried witha mirror but had no luck. I'll look for diff angles.

so are you saying that I might have leak in the actual heater core, or in a hose on that end?
04-14-2010 11:36 PM
JeepersdoitDeeper Get you a mirror and a small flashlight. The plug is on the back of the head, facing the firewall. Hold a small mirror and use the light to visualize it. You should be able to see signs of leaking if there is a hole or corrosion.

For the heater core, one way you can check for a leak without removing. Disconnect the small heater hoses from the front, where they connect at the front of the motor. Leave them connected to the firewall. Plug one with a finger good and snug, and blow pretty hard on the other one. If you have a decent leak at the heater core, you'll have air blowing off at the firewall.

Kinda ghetto way to check, but if you dont have the proper tool to pressure up the system, it's a quick shadetree method.
04-14-2010 11:29 PM
jconway jeepers: yeah, i f-ed that up, posting twice and cant figure out how to delete one of them.

thanks for the advice. any idea how to ascertain hose or plug?
04-14-2010 11:25 PM
JeepersdoitDeeper Looks like you have this posted twice. I posted a response on the other one.
04-14-2010 11:12 PM
pokey How much water is leaking? Do you have to add coolant, or is it staying pretty much full? It may just be coming out of the overflow bottle. I'm not real familiar with the heater core/hoses but it sounds like it could be related. Maybe a hose back there connecting the heater core.
04-14-2010 10:58 PM
jconway
water leak from behind engine block

re my 02 wrangler x, 6 cyl, 5-speed: i've got a water leak coming from somewhere behind the engine block, sort of on the passenger side. The engine does not run hot, and the oil is pure (no froth, evidence of water.) The water seems to be leaking just between engine and firewall (and dripping on oil sender unit) but I can't see a leaking hose. any idea what's back there? AND could it be related to why the heater seems to run cold at idle speed, but warms up when revved or driving?

any help would be great. thanks,

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:45 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC