Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Help !! - Webber Carb. problem

Join Wrangler Forum Today


Thread: Help !! - Webber Carb. problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-16-2010 06:20 PM
lykanjt Alrite, after a few days reading and messing around with that thing, I finally got it fixed. Turned out, there are 4 screw that hold down the first adapter and 4 more screw that hold down the second adapter. To my luck all 8 screw was loose. When the mechanic put the carb. in he didnt used threadlocker. So, I took the whole carb out and re-do it with threadlocker, now the hissing noise stopped. With new fuel filter and regulators, she's running like a champ.

Thanks for everything.
04-11-2010 02:56 AM
tlrrob1000 Not a problem. Fuel bowl is in the front of the carb. See where the fuel line coming from the fuel filter goes into the carb. It is located there. This carb is not a big deal to build. They just have issues with crap getting in them. Clean fuel and keep up on your filter and you will be ok after the rebuild. As far as an adapter there should not be one. The original gasket looks like it is an adapter. There should not be any play there. Do you have a picture?
04-07-2010 02:03 PM
lykanjt First, thank-you for y'all reply.

I've read up on it and even in the installation guide, they recomended the fuel regulators at 3.5 psi. Could that be the reason why ?

Where is the "fuel bowl" located, i google it and it the gas tank .. lol .. can you point me in the right direction and picture help .. thanks in advance.

Hissing noise, I found out what's wrong with it, it's the adapter. This is where the carb sit on, there are 2 piece adapter, it have 4 bolt all around, and i checked them all, it's TIGHT, but you can wiggle it and the gap is between the 2 adapter ... any idea ? I did not installed the carb initially so i dont know how that assembly goes in, I paid a mechanic $100 to install it, now if i want him to look at it again, im sure he's gonna charge me and also said it wasnt his fault blah blah blah .. so should I took the carb out and redo it myself ? any suggestion of why there's a gap between the 2 adapter ?
04-07-2010 11:39 AM
tlrrob1000 OC California. Talking Smog here. Can't pass visual inspection with the other carbs. Getting tougher here everyday.
I agree Scott sounds like the float is not high enough. If you are going to get into the carb buy a rebuild kit and clean it out and reset everything. $20.00 and it will run great. Hissing would be vacuum.
04-06-2010 10:33 PM
scott howard it is starving for fuel when you go down a steep hill because it is not able to pick up fuel from the bowl.
make sure your fuel level is set as high as possible without flooding out or add a piece of fuel line to the pick up in the bowl so it is able to stay in the fuel pool even on steep hills.
the hissing has to be a vacuum leak from the base or a hose should be easy to find and fix.
or buy a motorcraft 2100 carb and replace the webber .
or if you are loaded change it all to fuel injection and have the very very best.
04-06-2010 09:26 PM
lykanjt
Help !! - Webber Carb. problem

Recently I have a problem with my Webber 34 DGEC carb. The jeep will stall when I go down hill, dont know why ? even if i put it in gear it still stall. So, I messed around with the carb Idle screw and the Mixture screw. I got it to be a little better, on steep slope, it still stall but it's better. Now, I have a bigger problem, the carb started to make this loud hissing noise, it's one of those really anyoing hissing noise, I think because it's taking in too much air, or putting out too much air or something. I've read on all the forums looking for help, but appearantly no one have this problem .. lol .. Please, if someone on here can help me out, because I am this close to put a sledge hammer throught that carb...

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:57 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC