Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Trouble with stalling/difficult starting...

Join Wrangler Forum Today


Thread: Trouble with stalling/difficult starting... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-22-2010 11:57 PM
DontTellMeAboutCajun It can be sooo many things, but here's my similar-to-yours story and what happened:

Friend has an older Civic hatchback that broke down so I came out to lend a hand. He said it'd backfired real hard then immediately quit and wouldn't start. The backfire blew the intake tube clean off the throttle body, lol. Anyway, when turning over it'd hiccup, pop, catch every other cylinder, etc. but just wouldn't run. Soooo, long story (and many hours of head-scratching) but I eventually discovered that the set screw holding the rotor to the shaft had fallen out. The shaft would occasionally catch the rotor and turn it (the hiccups and pops!) but mostly would just turn inside the rotor.

Crazy, i know....but could be something as simple as that. Check.
04-22-2010 10:15 PM
CSmith1128
Trouble with stalling/difficult starting...

I'm having some problems with my 97 wrangler and I'm trying to fix it myself so I don't have to tow it to my mechanic.

For some reason it keeps stalling on me. A few months ago it was idling rough and I had a crankshaft position sensor error code, so I replaced it and it fixed that problem. A few months later I was driving down the highway and it stalled on me so I drifted to the side of the road. I tried starting it, but it wouldn't start. I waited a couple minutes, tried starting it and it started up. I started to drive again and it stalled and backfired. I tried starting it and it wouldnt start. I waited again and it started up and I drove it for about 2 hours without any problems. The next day I started it and it ran, so I tried driving it and it stalled. This time I tried several times but it wouldnt start.

I then had it towed to my mechanic and he said it wasn't getting a spark. He changed the distributor pickup and it seemed to fix the problem.

It ran well for a couple months, then it started having trouble starting. It would take abnormally long to start.

I looked under the hood and noticed the distributor cap screws came loose, so I tightened them up and it seemed to fix the problem for a couple days.

I went to drive it a few days ago, and it stalled out about 2 minutes down the road like it did before I had the distributor pickup replaced. I tried starting it, but it wouldnt start. I waited about 5 minutes and tried to start it and it started. I was able to drive it back home without any problems.

The next day I tried starting it, but it was having trouble starting. It would start, then stall a few seconds later while it was idling. Then it would take a couple tries before it would start again. After it started, it ran fine while it was sitting there. It didn't stall at all and it ran for about 10 minutes.

Then next day I went out and tried to start it and it shook a little bit while I was turning the key and it sounded like it was started and it shut off, then sounded like it was started then shut off, all while i was still turning the key trying to start it. It ended up not starting.

That was the last time I tried to start it and I want to see if I can try some things tomorrow to figure it out.

Anyone have any idea where I should start or what the problem could be?

I have a feeling that it has something to do with the spark or the fuel delivery, but I'm not a mechanic so I have no idea.

I read somewhere that it could be the fuel pressure regulator, but it is attached to my fuel pump inside the gas tank. I don't want to have drop the tank to test it if I dont have to.

Here is what I have done so far:
- I changed the oil about 2 weeks ago
- I changed the spark plugs, distributor cap and rotor after the car stalled out the last time.
- My mechanic checked and he said he didn't notice any problems with the head gasket.
- The muffler and catalytic converter need to be replaced, which I'll probably do tomorrow.
- I cleaned the air filter (K&N)
- The spark plug wires look fine.
- I disconnected each of the fuel injector connections 1 by 1 to see if they were working and they seemed fine.

I think that is everything.

Does anyone have any ideas as to what could be the problem or what I should check?

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:00 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC