Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Help Water Pump

Join Wrangler Forum Today


Thread: Help Water Pump Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-12-2010 09:57 AM
Jerry Bransford I never use anything but the standard paper gasket whenever installing a water pump or thermostat. There's no need for RTV or anything else. The one thing to be super conscientious about is that the two surfaces have to be THOROUGHLY cleaned of any old gasket material. Any speck left, even one you can barely see, will usually cause a leak.
06-12-2010 07:12 AM
JimboJeep thanks for all of the feed back ,I took apart again the the gasket on the water pump looked like a peice of swiss cheese in an oven. Got a new "better" gasket and reinstalled everything and seems to be working. I would suggest not using a gasket sealer as that is what seem to make the gasket fall apart. Just some antifreeze to hold it on the pump when you install.
06-06-2010 03:13 PM
JimboJeep So I put it all back together with new pump and thermostat housing and it started to leek as soon as I put the anitfreeze in from the same spot. Drained and took apart and the new gasket looked terrible. Got a new Gasket and carefully put all back together. Started looking for the same spot agin! No clue what I am missing but this is about 8 hours of work and about to give up. got any suggestion before I take it to the shop?
05-28-2010 10:47 AM
jtraider did you take the bolt out of the power steering bracket?
05-27-2010 09:36 PM
Jerry Bransford It is just being held by the gasket, perhaps someone used stick-um on it where they shouldn't have. Give the pump a good whack from the side being careful to keep the whacker from where the pump seals against the block.
05-27-2010 09:22 PM
JimboJeep Should it come up and out, seem the braket for the power sterring is in the say and I cannot seem to loosen enough to move it?
05-27-2010 08:18 PM
drivebytruckerz I gently put a crowbar behind the piece where the bell bolts back to and just pried it off. Be easy.. you don't want to damage your radiator..
05-27-2010 08:08 PM
JimboJeep
Help Water Pump

Okay, got all the bolts out (6), hoses off, but cannot see how I get it out of there and it wont't budge.
Got any helpful hints?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:01 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC