Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > annoying Soft top wind noise??anyone??

Join Wrangler Forum Today


Thread: annoying Soft top wind noise??anyone?? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-02-2010 01:28 PM
d3digit I think I found out what it was. First thing I tried last nights was I took my computer mouse pad I put it where the foam is and close the top just to see if its not closing properly but it made the same noise. So the foam wasn't the issue. This morning I took the top off and check closely the entire top and notice a tiny rip in the top right at the edge of the seam in front that I coundt see from a feet away about a quarter inch so got inside and I put a mouse pad right in between the cloth and the plastic header and reduce the noise a lot. Sounds like Im making a dealer appoinment at this time.
Thank guys for all the advice
06-02-2010 11:09 AM
OSUJEEPER Search "Soft top wind Noise" on the forum. I had this problem, it was so loud that on the highway I had to scream to get anoone to hear me. There should be a thread with a TSB for the dealer. I took it in and gave them that #, much better now.
06-01-2010 09:15 PM
Always JK'n I've had a TON of frustration with this.

I took it back to the dealer and they replaced the plastic header on my 2007 sport with a metal one (for free because of a technical service bulletin...ask about it). It helped some, but there is still pretty significant wind noise.
06-01-2010 07:43 PM
phottomatt I had this problem also but after putting the top back on I stand on the side step and look across the front edge of the top, between the top and the windshield should be flush. Sometimes the rubber strip will stick up in short sections and creates a lot of noise. I think you said that you already looked at that but make sure the rubber strip is tucked in all the way. If it isn't just run your finger along the section that is up with a little pressure and that will tuck it back down in.
06-01-2010 07:28 PM
Geoff@Bestop I think your windshield header is a little bent. Try having someone push down in the middle (red arrow area) of your windshield header, then clamp it in.

Maybe even try rebending it - with the top off (or at least disconnected from windsheild) try slightly bending the header back to normal. It's just a little bitty gap - don't overdo this.

Did you remove the fabric from the header, or did it stay with the fabric top? (it should have stayed). If you removed it, you may have other issues.

Let me know.
06-01-2010 05:26 PM
d3digit thank guy
I first took off the two front clamps and lift it off to check the foam, It was fine, every thing in the back windows are fine. I put it back on, Same noise. The second time I did a close inspection on the front. It look like the air comes in from where the arrows in the pic are, where that plastic concave is barely touching the foam
06-01-2010 04:42 PM
TDCoffee I have had the same issue, and am wondering if the cause isn't a little bit of foam stripping between the header and the top. I found these random bits of adhesive backed foam stuck to my seats, (as if they had fallen off of something, but couldn't figure out where. Yesterday I noticed a piece of the foam stuck to the header bar of the top.

What do you guys think? if I/We replaced these bits of foam with something from Lowes or Home Depot or whatever, do you think it would help? Anyone tried this? I think I'm going to give it a try. I'll let you know if it works.
06-01-2010 04:11 PM
sevenservices x2 to take it off and put it back on the windshield...

Also, ensure all parts going together are clean.


Or, get those knarly tires and turn up the radio!
06-01-2010 03:53 PM
clear lake jeepn Try getting some big knarly MT's......they will drone out the wind noise!!
06-01-2010 03:34 PM
PTaylor Try taking it off and putting it back together again? did it make a difference? Everything locked down correctly?
06-01-2010 03:33 PM
bigjay0512 Mine did this the first couple times I had my top off also, not exactly sure why, but it just stopped making the noise one day and hasn't came back when I rarely do have the top up.
06-01-2010 03:22 PM
d3digit
annoying Soft top wind noise??anyone??

I took the Soft top off for the first time las week, Yesterday after I put it back on, now I have a wind noise coming from the front( right in the middle where the little hitch is to attach the windshield when is down) its starts around 20mph) I check the foam seal and it looks like is in the right place. It didnt make any noise before I took the top off( it was nice and quiet ). Does anyone have experience any similar thing???Should I take it back to dealer??? Its a pretty annoying sound

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:29 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC