Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Complete loss of power

Join Wrangler Forum Today


Thread: Complete loss of power Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-11-2010 07:55 AM
sevenservices check all your connections first on both side of the battery cables.

be sure your terminals are all ruffed up and clean with sand paper or a wire brush.

check the battery cable just before each end to ensure it did not burn or break inside the insulation, just behind the terminal where it bends.

turn the key on, jump the starter leads with a screwdriver to see if it bumps the engine over. If it does, you know for sure the problem is in your push button wiring somewhere. If it does not bump the engine over, your battery is shot or your cables are shot/loose/dirty.
06-11-2010 07:36 AM
motoup4662
Complete loss of power

I was away from the house when my wife tried to move my Jeep. She said she got in it and hit the start button and something clicked under the dash. I thought she just killed the battery but after charging it I still have complete loss of electrical. Any ideas as to where I should start? Sounds to my like some sort of relay or fuse might have blown but I wasn't sure if there was anything ignition related under the dash that would cut out all power...


Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:13 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC