Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 2001 Jeep Wrangler battery or otherwise issue

Join Wrangler Forum Today


Thread: 2001 Jeep Wrangler battery or otherwise issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-17-2010 11:43 PM
Bobthegod First do the easy thing.....remove, clean and replace (retighten) all the battery cables especially the one the goes to the relay box. You may think WTF that couldn't be it. But if they are loose and/or dirty you will have a plethera of problems.
06-16-2010 04:12 PM
wasurfer86 i was having the same problem and ended up replacing the battery even though it tested out good. i could see a steady decline in how long it took to start up each day for a week. knock on wood that it keeps starting up.
06-16-2010 04:10 PM
wasurfer86 i would take it to sears and get it tested. they should test the starter, alternator, and battery for about $20. if all is good try tracing all wiring from the battery and make sure there arent any tears. if that looks good see if the battery connections to the starter are loose. if thats good try cleaning the battery posts and cables. use a baking soda water mix and an old toothbrush.
06-16-2010 03:57 PM
obiwon
2001 Jeep Wrangler battery or otherwise issue

Last month, I left work and my battery was dead. No problem. Jumped it and drove great for a little over a month.Yesterday, went out after work and battery dead again but this time there was a beeping noise coming from under the hood on the drivers side and my speedometer, tachometer and several other gauges were jumping up and down like crazy. If I turned the switch on, they stopped but still no battery power at all.

Jumped it again and was okay but felt a little sluggish in response this time. Started it this morning and same sluggish a little but drove to work. Just went outside and tried again and it started but barely. I could not take my foot off the gas or it would quit. Start again and was like cranking was very slow on battery rather than the normal crank and it starts. It did start but took foot off gas and died again.

any ideas? Battery or fuel filter or both or something along those lines?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:00 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC