Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > What would cause excessive oil pressure in valve cover?

Join Wrangler Forum Today


Thread: What would cause excessive oil pressure in valve cover? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-05-2010 05:19 PM
jpwrangler96 well i was just reading that the oil passageways could be blocked causing the problem how would you go about cleaning them if that was it?
07-05-2010 05:12 PM
jpdocdave make sure no pcv port is plugged.
07-05-2010 04:58 PM
jpwrangler96
What would cause excessive oil pressure in valve cover?

Im a newbie to the wranglers, i just bought a 88 yj with the 4.2 when i got it the valve cover and block where covered in oil. I cleaned it up replaced both seals for the pcv valve and the breather changed the pcv valve, and a new oil cap. Also changed the oil and air filter and noticed there was alot of oil in the pan and up through the intake cleaned it up and It was fine for a week or so then the oil pressure gauge was constantly pinned passed 80 during driving. Oil was all over the left side of the motor so i figured it was the gasket i changed it yesterday with a cork one from a&a started it up and saw the oil was still pushing up around the filler cap and pcv valve seal, so if anyone could tell me what would cause there to be too much oil pressure there id appreciate it oh and i don't think it has anything to do with this but the same time the gasket went the temp gauge stopped working

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:59 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC