Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Ride Questions from recent 4" Lift

Join Wrangler Forum Today


Thread: Ride Questions from recent 4" Lift Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-23-2010 02:21 PM
mrcarcrazy I need face-Palm image...


Lance, you think way too much like me. That's hilarious.
07-23-2010 02:13 PM
lancetkenyon You should have taken it out and flexed it, THEN tell us it didn't rub.

Anyway......the rattle could be:
1. Your throwout bearing in you clutch
2. Any loose bolt from the install
3. Did you get an SYE and CV DS? If not, it could be your DS binding a touch-when you take off in 1st, your motor torques and causes your engine/tranny/t-case to twist and the rear pinion angle to change slightly.

As for ride quality, I am betting you have a 4" short arm, and hate to say it, but you get what you pay for with certain things. Especially lifts. A 4" SA is about as high as you can go with that set up, any higher really needs a long arm kit, and even a 4" lift benefits from a long arm set up. Yor control arms are not at an optimal angle for ride quality, and push the axle back more on the frame side mounts instead of pushing the axle up when you hit a bump.

What can help? Softer shocks, better coil springs, a high qaulity lift, long arms, softer seats, ass donut, spine replacement, airing down the tires, Jello brand body mounts, carrying gummy bears in your back pockets, eating a lot of carbs and letting your butt get flabby, truckers air ride seat.
07-23-2010 12:34 PM
97Hodgie I'm still stuck on the part about
Quote:
Originally Posted by 97Hodgie
...I bought it and put 33X12.5X15" BFG A/T's on it. Believe it or not, they fit with no rubbing...

and then later in same post
Quote:
Originally Posted by 97Hodgie
So ONLY because the fender flares rubbed the tires everytime I hit a pothole, I decided to get a 4" suspension lift.


The tires didn't rub anything when I was turning or during normal driving. The fender flares rubbed on the tires when I hit a pothole about 8-9" deep or more. If I had installed flat fender flares, the tires wouldn't have rubbed on anything with no lift required (but I don't like the look of them as much).
07-23-2010 08:55 AM
mrcarcrazy I'm still stuck on the part about
Quote:
Originally Posted by 97Hodgie View Post
...I bought it and put 33X12.5X15" BFG A/T's on it. Believe it or not, they fit with no rubbing...
and then later in same post
Quote:
Originally Posted by 97Hodgie View Post
So ONLY because the fender flares rubbed the tires everytime I hit a pothole, I decided to get a 4" suspension lift.

wait I'm Confused.


to the question at hand. I've heard more than a few complaints about the ride on skyjacker kits. That's why I'm primarily only looking at OME...(they seem to get the least complaints.)
07-23-2010 08:48 AM
InfernoGirl Welcome to the forum!

The rattle may be due to the shifter linkage binding, if they didn't adjust it after the lift.
Did you get an alignment after lifting it? Lifting changes the angle of everything and all those changes need to be addressed to regain pre-lift status.
The ride quality is likely due to a combination of things... check the air pressure in the tires, around 28psi is usually good for 33's.. and iirc, the hydro shocks are pretty rough riding shocks, (I could be way off on that statement, memory is crappy.. ) The coils should be ok.
Check the Ujoints for wear, worn ones can cause a pretty crummy ride.

That's all I got.... Someone with more experience with these things will be along shortly to offer more assistance.
07-23-2010 01:19 AM
97Hodgie
Ride Questions from recent 4" Lift

Hey everyone, new to the forum...glad to be here! I'll get some pics up in the next few days to make it official!

I have '97 TJ 4.0 w/ soft top that was stock until January when I bought it and put 33X12.5X15" BFG A/T's on it. Believe it or not, they fit with no rubbing because of the rims that were already on it...I was ecstatic. Before I put them on, the Jeep wobbled back and forth sideways whenever I hit a bump or dip (not the Death wobble, just a little wobble). After the 33's were installed, there was no more wobble and the ride was amazingly smooth (for a Wrangler), I mean it was car-like on the road! So ONLY because the fender flares rubbed the tires everytime I hit a pothole, I decided to get a 4" suspension lift. I went with the Skyjacker Econo 4" Lift w/ Hydro Shocks (don't judge me)...here's the link
Skyjacker 4" Economy Lift Kit with Hydro Shocks for 97-02 Jeep® Wrangler TJ - Quadratec

My question is: Now that it has the 4"lift, the wobble from side to side is back when I hit a bump, there is a rattle that sounds like its coming from the tranny only when I accelerate hard in first gear, and the ride is much worse now...all because of the lift. It took me a while to get my shop to put everything on, so is there anything I can do now to leave it all on and maybe swap out a few things for different ones...like maybe just swap just the coils or just the shocks...or even just bushings or something? When it comes to suspension parts, I am lost! I don't offroad that much, mostly just dirt trails so I don't need anything extreme...just hopefully a minor fix to this problem. And what's that rattle in first? I've read about other people that have it just when accelerating in first.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:20 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC