Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > No brake lights, no turn signals, what's going on

Join Wrangler Forum Today


Thread: No brake lights, no turn signals, what's going on Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-02-2010 05:51 AM
fonecop1 Like I said mine was sitting for 2 years. So far I had problems with the blinker switch but it's now working. When you try to adjust the radio volume sometimes it takes 4 or 5 clicks before it starts to adjust. Also I have had times where you hit the key and it don't start till about the 4th or 5th try while cycling the key and depressing the clutch, I think either the ignition switch or the switch for the clutch is causing that. I may put a $40 ignition switch in it if it gets to be a bigger problem. Considering I bought the Jeep for less than half of "poor condition" blue book value I aint compalining.
08-01-2010 10:02 PM
Texasjames1 Hahaha I don't know for sure, but I do know it has sat for over a year wherever it was sitting. The guy I bought it from just moved into the place he had 3 months before I bought the jeep. So I'm not 100% sure. I appreciate the help fellas.
08-01-2010 07:19 PM
fonecop1
Quote:
Originally Posted by Texasjames1 View Post
I also noticed that the wipers do not work, the wiper fluid will shoot, but the wipers will not. I'm wondering if the connector underneath the dash is disconnected would this be possible? I ask first because i don't want to rip out the dash if you guys have a better idea. Oh btw where is the "indicator stalk"
It's the blinker switch assembly. No need to tear out the dash just take the 3 phillips screws out of the bezel that goes around the steering column and take out the panel right below that by removing the 2 screws in it. Pretty easy to get to. Did this Jeep sit out in the weather?
08-01-2010 05:24 PM
Texasjames1 I also noticed that the wipers do not work, the wiper fluid will shoot, but the wipers will not. I'm wondering if the connector underneath the dash is disconnected would this be possible? I ask first because i don't want to rip out the dash if you guys have a better idea. Oh btw where is the "indicator stalk"
08-01-2010 07:00 AM
fonecop1 The dealer quoted me one for $51. My son picked one up at work for $48 and even though it was against my better judgment to replace it when it was working again, I installed the replacement and it was worse than the original. On the replacement when the right blinker came off the hazards would start flashing, not on the dash but on the outside until I switched it several times between right and left blinker. At that point I reinstalled the original and have been using it.
08-01-2010 01:03 AM
Coyote_94YJ x2 on the indicator stalk. Mine is kind of intermittent and I need to get it fixed but I'm being lazy.
07-31-2010 08:30 PM
fonecop1 Need to replace the turn signal stalk, also I think they call it the multi function switch. Mine was doing the same thing and I didn't think it had anything to do with the brake lights but it does I guess because the hazard switch is on it. Before I replaced mine a friend just started flipping it back and forth between right blinker and left blinker really fast and it started working. My jeep had been sitting for 2 years under a carport with the side windows and the back window off so I figure it was corroded from the moisture. Try getting rough with yours because it's broke anyway.
07-31-2010 06:47 PM
Texasjames1
No brake lights, no turn signals, what's going on

The title says it all. I have no brake lights, and no working turn signals. My headlights and tail lights work but not the actual brake lights. I checked all the fuses, they were good. I just bought er' she's a 97 wrangler. 4cyl. Any help or advice is greatly appreciated. I noticed that there is a spot for an ABS relay, and an ABS fuse. My brakes work, and i don't have any notification of a faulty system so i only assume i don't have ABS. I still don't know what to do about the turn signals because i checked the bulbs and they are intact. I don't think i have abs but my next move will be to switch around relays, but i do not want to mess something up either.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:00 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC