Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > possible ac issues?

Join Wrangler Forum Today


Thread: possible ac issues? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-22-2010 05:54 PM
Bok666choy I ran into a problem with my 2000 where that started happening then after a while the fan started cutting out for a couple minutes then come back on... Finally the fan stopped completely and wouldnt turn on it turned out that the wiring harness had melted... Don't know if the problems the same but I've found most jeeps loose there ac abilities earlier than most other cars out there but Im guessing it's cause most jeepers would rather spend 500-1000$ on something better than an ac and you can take the top off for free =D
08-20-2010 08:46 PM
Hoganoga
possible ac issues?

Just wondering if anyone else has ran into this problem and my be able to diagnose it. When I turn my ac on in my 03 wrangler nothing comes out of the vents for the first 10 to 15 secs then if blows fine and cold, at least cold for AZ standards. I have one of those ac recharge store bought cans with the gauge on it, and I hooked it up to see if maybe it needs a charge but the needle goes to the red section and it reads take to mechanic problem with ac unit? So if anyone has some suggestions on what to try first before going to a shop please let me know. Everything seems fine to me other than the delay but should I trust that gauge reading on a $10 can of recharge and take it in before something goes out? Any help is much appreciated and thank you for your time guys.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC