Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Parking Brake light

Join Wrangler Forum Today


Thread: Parking Brake light Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-22-2010 08:21 AM
JpAdct I forgot to add that it does have the D44 rear with disks. Not sure what that would matter but it might??? The parking brake is not dragging either.
08-21-2010 09:56 PM
JpAdct
Parking Brake light

I got my 2006 Wrangler back yesterday from getting some front axle work done. Now the parking brake light won't go off on the dash. I used a friend of a friend and he claims the light was on when he first got in it to move it. I've checked the brake fluid and it is good, I took the console off and tried to adjust the little tab/ground piece that opens the circuit when you put the parking brake lever down and causes the light to go off. I also moved this tab around while there and the light never would go off. I've searched for leaks and can't find any but didn't expect any since the fluid was good. For giggles I also disconnected the battery and ran OBD II tests but got nothing on either. The Jeep seems to be stopping just fine so I am baffled here. It would be bad enough if the light were staying on, but it also beeps at me for about 5 seconds any time I stop for more than 5 seconds. It is set up to give a reminder each time you take off because it thinks the parking brake is on. So basically there is no driving it right now as that beeping noise sends me over my limits. I have searched online and everybody says to check the fluid, look for leaks, adjust the tab in the console. Well I did and I got no results?

I read on this site too where several YJ owners have this problem but I can't find anything for a TJ
If anybody knows what this could be, PLEASE HELP as it is driving me CRAZY!!!
Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC