Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 01 Sahara 4.0 Help! Stalling!!

Join Wrangler Forum Today


Thread: 01 Sahara 4.0 Help! Stalling!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-20-2010 01:03 AM
Kauka I was having issues with my jeep stalling and the gages bouncing eraticlly. I had it checked out and was told it was the voltage regulator, of course that is build in to the altinator. However the new one did the same thing, so I got my money back. Ended up replacing the battery with a Wal-mart one, it fixed it for about 6 months, then it started acting up again. This last time I replaced it with a good quality battery and I haven't had an issued, that was two years ago.
09-19-2010 10:59 PM
supernova1021 No one else have any opinions?? This is like the third time I have posted this on here looking for help and Pokey is the only one with any input. Thank you Pokey.
09-19-2010 07:24 PM
supernova1021 I thought about that. The battery (Wal-Mart brand) was put in in 08. I'll get it tested tomorrow.
09-19-2010 06:53 PM
pokey It could just be you need a new battery. If the battery is almost dead, the engine will run rough and stall. The alternator won't be enough to keep it running smoothly. Have them check the battery first. Good luck.
09-19-2010 06:02 PM
supernova1021
01 Sahara 4.0 Help! Stalling!!

Bought 01 4.0 Automatic with about 120K miles on it. The dealer said if anything happened to bring it back and he would fix it before I bought it. Well, it started stalling while driving and it was very hard to get back started. Usually had to wait five minutes or so.

It showed a code P0320 (crankshaft position sensor) so the dealer replaced that, the camshaft position sensor AND the computer. He told me the fuel pressure tested fine. Brought it back to me and it drove fine for a day. Today it started stalling again. I did the key thing and it still showed the same code. I checked the battery connectors and the positive was a little dirty and seemed a little loose. I took it off and cleaned it really good and left it unhooked for about 15 minutes to clear the code. Put it back together and started up just fine.

Any ideas of what else could be going wrong with it since they have replaced all those parts? I'm taking it back to them tomorrow.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:36 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC